Boot Repair [grub-efi-amd64-signed] Sorunu (Kali Linux Dual Boot)

Bu konuyu okuyanlar

Hopeツ︎

Profesör
Emektar
Katılım
9 Mart 2016
Mesajlar
1,851
Çözümler
1
Reaksiyon puanı
1,892
Puanları
113
Yaş
24
refind ile halletmek istedik, paket yüklenemediği için geçemedik. Neyseki çözümü buldun :)
Kesinlikle paket yüklemelerinde artık sorun oluşmayacağı için refind tekrar denenebilir durumda artık.

ben bozup geri yapmışlığım var :D efi den silerim kaliyi çözülür eğer bozulursa :D bağlarken şu açıdan şimdi bu uygulamayı indirip çözecektik ama indirmeler olamadığı için çözemedik suçlu kim o list komutu bu anlamda :D yoksa tabiki de biliyorum güncellemeler olunca GRUB problemi kendiliğinden gitmeyecek
Depo bağlantılarını günah keçisi ilan ediyoruz o zaman = ))
 

Q_sySZero

Asistan
Katılım
7 Nisan 2018
Mesajlar
120
Reaksiyon puanı
7
Puanları
18
Yaş
21
onu da silerim o neymiş :D harbi ne ki o :D açın biraz

---- Mesajlar birleştirildi ----

onu da silerim o neymiş :D harbi ne ki o :D açın biraz
HAha hhea anladım tamam jeton düştü şimdi depo bağlantısı

---- Mesajlar birleştirildi ----

açılışta gereki ön yükleme bilgisini barındıran efi de ki dosyalar :D gerekli depolama birimlerini yüklüyo :D

---- Mesajlar birleştirildi ----

HAni ince mince :D doğru düzgün linux bilgim olsa buralara hiç adım atmam da cahillikten daha başlandıçta olunca sürünüyoz işte
 
Son düzenleme:

rise

Dekan
Emektar
Katılım
12 Ocak 2009
Mesajlar
9,898
Reaksiyon puanı
3,251
Puanları
113
Bu da final olsun :)
 

Ekli dosyalar

  • Screenshot from 2018-04-09 03-56-21.png
    Screenshot from 2018-04-09 03-56-21.png
    454.8 KB · Görüntüleme: 439

Hopeツ︎

Profesör
Emektar
Katılım
9 Mart 2016
Mesajlar
1,851
Çözümler
1
Reaksiyon puanı
1,892
Puanları
113
Yaş
24
HAni ince mince :D doğru düzgün linux bilgim olsa buralara hiç adım atmam da cahillikten daha başlandıçta olunca sürünüyoz işte
At bence adımını buralara, Linux kategorimiz var... Bu kategoride bir çok bilgili dostumuz var. Dostlarımızın açtığı güzel konular var takıldığın yerlerde yardım alabileceğin mesela. Söylüyorum sadece tercih senin elbette :)
 

Q_sySZero

Asistan
Katılım
7 Nisan 2018
Mesajlar
120
Reaksiyon puanı
7
Puanları
18
Yaş
21
At bence adımını buralara, Linux kategorimiz var... Bu kategoride bir çok bilgili dostumuz var. Dostlarımızın açtığı güzel konular var takıldığın yerlerde yardım alabileceğin mesela. Söylüyorum sadece tercih senin elbette :)

:) Felix Abimiz kızmasın sonra hep kali linux :) diye
 

Hopeツ︎

Profesör
Emektar
Katılım
9 Mart 2016
Mesajlar
1,851
Çözümler
1
Reaksiyon puanı
1,892
Puanları
113
Yaş
24
:) Felix Abimiz kızmasın sonra hep kali linux :) diye
Aslında kimse kimseye kızmıyor, forumda bir şeyler yazıp çiziyorsak kendi isteğimizle biri diretmiyor sonuç olarak. Zaten önceki gönderilerinde bu işi gönüllü şekilde yaptığımızı belirtmişti bende aynen katılıyorum. Konuyu biraz daha açmak gerekirse... Bende dahil Linux kullanılıp öğrenilmek isteniliyorsa eğer normal amaçlı dağıtımlar öneriyoruz ve bunların üzerinde ilerliyoruz. Yani Kali Linux'a da bir dargınlığımız yok, sadece bir pentest dağıtımı ve illegal işlere yol açabilecek kapasitede bir dağıtım. Kali ile alakalı bir konuyu gördüğümüzde ya da yorumladığımızda sanki bu illegal işe destek veriyormuş gibi hissediyoruz ve bu da bizi rahatsız ediyor. Daha legal bir bakış açısının zararsız olacağını aşılamak asıl niyetimiz. Katoolin ile normal amaçlı diye tabir ettiğim dağıtımlara bu pentest yazılımlarının yüklenme ihtimali var mı? evet var. Fakat bu zamana kadar kali linux ile uğraşmamış birinin gidip kullandığı legal dağıtıma katoolin yüklediğine henüz şahit olmadım. Zaten kullanıcı hacking işleriyle bağlantılı olmadığı için otomatik olarak katoolinden'de habersiz kalıyor. Durum özetle bu şekilde, umarım anlatabilmişimdir.
 
Son düzenleme:
Katılım
4 Haziran 2008
Mesajlar
11,494
Reaksiyon puanı
2,244
Puanları
113
Aslında kimse kimseye kızmıyor, forumda bir şeyler yazıp çiziyorsak kendi isteğimizle biri diretmiyor sonuç olarak. Zaten önceki gönderilerinde bu işi gönüllü şekilde yaptığımızı belirtmişti bende aynen katılıyorum. Konuyu biraz daha açmak gerekirse... Bende dahil Linux kullanılıp öğrenilmek isteniliyorsa eğer normal amaçlı dağıtımlar öneriyoruz ve bunların üzerinde ilerliyoruz. Yani Kali Linux'a da bir dargınlığımız yok, sadece bir pentest dağıtımı ve illegal işlere yol açabilecek kapasitede bir dağıtım. Kali ile alakalı bir konuyu gördüğümüzde ya da yorumladığımızda sanki bu illegal işe destek veriyormuş gibi hissediyoruz ve bu da bizi rahatsız ediyor. Daha legal bir bakış açısının zararsız olacağını aşılamak asıl niyetimiz. Katoolin ile normal amaçlı diye tabir ettiğim dağıtımlara bu pentest yazılımlarının yüklenme ihtimali var mı? evet var. Fakat bu zamana kadar kali linux ile uğraşmamış birinin gidip kullandığı legal dağıtıma katoolin yüklediğine henüz şahit olmadım. Zaten kullanıcı hacking işleriyle bağlantılı olmadığı için otomatik olarak katoolinden'de habersiz kalıyor. Durum özetle bu şekilde, umarım anlatabilmişimdir.
İşin aslı milletin legali kefali çok da umurunda değil. İsterse banka hortumlasın da benim bankama elleşmesin mazallah para çekemeyiz. Sorun şu, Kali kurmak isteyen adamların (Tabii sözümüz meclisten dışarı, öyle bir şey görsem konuya girmezdim) zır cahilliği beni sinir ediyor. Yardım etmek isteyince öyle garip dönüşler alıyorum ki en sonunda adamları kendi halinde bırakıyorum. Şunu diyorum, biz annemizin karnından linux ile çıkmadık ama işin adabıyla ilerledik. Belli bir olgunluğa varmadan debian kurmadık, direkt oraya buraya atlamadık. Kali daha os-proberı dahi kullanıcıya bırakan bir dağıtım ve bu kali kullanıcısının tasarrufuna bırakılan bir şey. Hani konu sahibi önce Manjaro kurup üzerine pentest araçlarını kursa başı daha rahat ederdi mesela. Tabii neden kurdun diyip azarlamak işimiz değil, adam bir kere beğenip kurmuşsa ve dağıtım da zor gelmişse işin güzel tarafı Linux'u erkenden öğrenmiş olur.
 

Q_sySZero

Asistan
Katılım
7 Nisan 2018
Mesajlar
120
Reaksiyon puanı
7
Puanları
18
Yaş
21
İşin aslı milletin legali kefali çok da umurunda değil. İsterse banka hortumlasın da benim bankama elleşmesin mazallah para çekemeyiz. Sorun şu, Kali kurmak isteyen adamların (Tabii sözümüz meclisten dışarı, öyle bir şey görsem konuya girmezdim) zır cahilliği beni sinir ediyor. Yardım etmek isteyince öyle garip dönüşler alıyorum ki en sonunda adamları kendi halinde bırakıyorum. Şunu diyorum, biz annemizin karnından linux ile çıkmadık ama işin adabıyla ilerledik. Belli bir olgunluğa varmadan debian kurmadık, direkt oraya buraya atlamadık. Kali daha os-proberı dahi kullanıcıya bırakan bir dağıtım ve bu kali kullanıcısının tasarrufuna bırakılan bir şey. Hani konu sahibi önce Manjaro kurup üzerine pentest araçlarını kursa başı daha rahat ederdi mesela. Tabii neden kurdun diyip azarlamak işimiz değil, adam bir kere beğenip kurmuşsa ve dağıtım da zor gelmişse işin güzel tarafı Linux'u erkenden öğrenmiş olur.
Dediklerinizi çok iyi anladım :D ben zoru seven biriyim kontrolün bende olmasını isterim dediklerinize göre Kali Linux bir çok şeyi kullanıcıya bırakıyor ve onun yapıp kurmasını istiyor aslında bu başlangıç seviyesinde biri için kötü ama işi iyice kavrayıp ilerledikten sonra avantaj sağlamaz mı :D her şey sizde çünkü daha fazla müdahale etme olanağınız var (dediklerinizden anladığım kadarı ile) bende bunu istiyorum aslında ben bilgisayarımda sanal makineme kurupta rahat rahat kullanabilirdim hatta kurulu üstüne bide USB yede kurdum onda da var kali linux persistence şeklinde sırf denemek ve nasıl bişey olduğunu görmek için dual boot yaptım ve olurki ilerde herhangi bir nedenden bilgisayara kurmam gerekirse yüklü kalsın diye kurdum dual boot u bunlar hep merak :D kurcalamayı didiklemeye bozup dağıtmayı severim dediklerinize göre kali tam benim kafamda bir OS :)

---- Mesajlar birleştirildi ----

yani Kullanıcıya daah fazla iş yükü bırakması benim için iyi bişey :D GUI yerine teminal kullanmak gibi :D

---- Mesajlar birleştirildi ----

yani Kullanıcıya daah fazla iş yükü bırakması benim için iyi bişey :D
Aslında kimse kimseye kızmıyor, forumda bir şeyler yazıp çiziyorsak kendi isteğimizle biri diretmiyor sonuç olarak. Zaten önceki gönderilerinde bu işi gönüllü şekilde yaptığımızı belirtmişti bende aynen katılıyorum. Konuyu biraz daha açmak gerekirse... Bende dahil Linux kullanılıp öğrenilmek isteniliyorsa eğer normal amaçlı dağıtımlar öneriyoruz ve bunların üzerinde ilerliyoruz. Yani Kali Linux'a da bir dargınlığımız yok, sadece bir pentest dağıtımı ve illegal işlere yol açabilecek kapasitede bir dağıtım. Kali ile alakalı bir konuyu gördüğümüzde ya da yorumladığımızda sanki bu illegal işe destek veriyormuş gibi hissediyoruz ve bu da bizi rahatsız ediyor. Daha legal bir bakış açısının zararsız olacağını aşılamak asıl niyetimiz. Katoolin ile normal amaçlı diye tabir ettiğim dağıtımlara bu pentest yazılımlarının yüklenme ihtimali var mı? evet var. Fakat bu zamana kadar kali linux ile uğraşmamış birinin gidip kullandığı legal dağıtıma katoolin yüklediğine henüz şahit olmadım. Zaten kullanıcı hacking işleriyle bağlantılı olmadığı için otomatik olarak katoolinden'de habersiz kalıyor. Durum özetle bu şekilde, umarım anlatabilmişimdir.
Amacım insanlarımn bilgilerini çalmak değil kendimi bilişim güvenliği konusunda geliştirmek istiyorum :D tabi bu dediklerim sizi tatmin etmez ama ona bakarsanız her evde bıçak var herkes katil mi :)
 
Son düzenleme:

rise

Dekan
Emektar
Katılım
12 Ocak 2009
Mesajlar
9,898
Reaksiyon puanı
3,251
Puanları
113
Amacım insanlarımn bilgilerini çalmak değil kendimi bilişim güvenliği konusunda geliştirmek istiyorum :D tabi bu dediklerim sizi tatmin etmez ama ona bakarsanız her evde bıçak var herkes katil mi :)
Bütün mesele budur, insanların cebinde çakmak var diye suçlu saymıyoruz. Ya da öğrenip kendimizi savunmak, önceden tedbir almak amacıyla güvenlik konusunu öğrenmek taraftarıyım.
İşin özü niyetle başlayıp niyetle bitiyor.
 

Q_sySZero

Asistan
Katılım
7 Nisan 2018
Mesajlar
120
Reaksiyon puanı
7
Puanları
18
Yaş
21
Bütün mesele budur, insanların cebinde çakmak var diye suçlu saymıyoruz. Ya da öğrenip kendimizi savunmak, önceden tedbir almak amacıyla güvenlik konusunu öğrenmek taraftarıyım.
İşin özü niyetle başlayıp niyetle bitiyor.
aynen hocam :D gdebi paketibi kurdum ancak disk-upgarde komutunda hata veriyo :D

---- Mesajlar birleştirildi ----

aynı şekilde indir dediğiniz dosyayıda kurarken o 3 paket yüzünden hata veriyo çıktısını atacam :D şimdi

---- Mesajlar birleştirildi ----

Kod:
root@kali:~# sudo apt dist-upgrade
Paket listeleri okunuyor... Bitti
Bağımlılık ağacı oluşturuluyor       
Durum bilgisi okunuyor... Bitti     
Yükseltme hesaplanıyor... Bitti
Aşağıdaki paketler otomatik olarak kurulmuş ve artık bu paketlere gerek duyulmuyor:
  gir1.2-mutter-1 gir1.2-networkmanager-1.0 gir1.2-nmgtk-1.0
  gnome-themes-standard keepnote libchamplain-0.12-0 libcharls1
  libdigest-md5-file-perl libdns169 libfabric1 libfreerdp-cache1.1
  libfreerdp-client1.1 libfreerdp-codec1.1 libfreerdp-common1.1.0
  libfreerdp-core1.1 libfreerdp-crypto1.1 libfreerdp-gdi1.1
  libfreerdp-locale1.1 libfreerdp-primitives1.1 libfreerdp-utils1.1
  libgcr-3-common libgdcm2.8 libgl2ps1.4 libgnome-desktop-3-12 libgweather-3-6
  libhdf5-openmpi-100 libhttp-server-simple-perl libisc166 libjs-excanvas
  liblept5 libmagickcore-6.q16-3 libmagickcore-6.q16-3-extra
  libmagickwand-6.q16-3 libmpfr4 libmutter-1-0 libnetcdf-c++4 libnm-glib4
  libnm-gtk0 libnm-util2 libopencv-calib3d3.2 libopencv-contrib3.2
  libopencv-core3.2 libopencv-features2d3.2 libopencv-flann3.2
  libopencv-highgui3.2 libopencv-imgcodecs3.2 libopencv-imgproc3.2
  libopencv-ml3.2 libopencv-objdetect3.2 libopencv-photo3.2 libopencv-shape3.2
  libopencv-stitching3.2 libopencv-superres3.2 libopencv-video3.2
  libopencv-videoio3.2 libopencv-videostab3.2 libopencv-viz3.2 libopenexr22
  libopenmpi2 libpoppler68 libpoppler72 libproj12 libpsm-infinipath1
  libqgis-analysis2.14.21 libqgis-core2.14.21 libqgis-gui2.14.21
  libqgis-networkanalysis2.14.21 libqgis-server2.14.21 libqgispython2.14.21
  libqwt5-qt4 libradare2-2.1 libruby2.3 libsocket++1 libsrtp0 libtbb2
  libtesseract4 libtxc-dxtn-s2tc libvpx4 libvtk6.3 libwinpr-crt0.1
  libwinpr-crypto0.1 libwinpr-dsparse0.1 libwinpr-environment0.1
  libwinpr-file0.1 libwinpr-handle0.1 libwinpr-heap0.1 libwinpr-input0.1
  libwinpr-interlocked0.1 libwinpr-library0.1 libwinpr-path0.1
  libwinpr-pool0.1 libwinpr-registry0.1 libwinpr-rpc0.1 libwinpr-sspi0.1
  libwinpr-synch0.1 libwinpr-sysinfo0.1 libwinpr-thread0.1 libwinpr-utils0.1
  libwww-mechanize-perl libx264-148 libxfont1 multiarch-support openjdk-8-jdk
  openjdk-8-jdk-headless openmpi-bin openmpi-common php7.0-mysql
  python-functools32 python-httpretty python3-construct python3-cssutils
  python3-feedparser python3-html2text readpst ruby2.3 ruby2.3-dev sbsigntool
  vino
Bu paketleri kaldırmak için 'sudo apt autoremove' komutunu kullanın.
0 paket yükseltilecek, 0 yeni paket kurulacak, 0 paket kaldırılacak ve 0 paket yükseltilmeyecek.
3 paket tam olarak kurulmayacak ya da kaldırılmayacak.
Bu işlem tamamlandıktan sonra 0 B ek disk alanı kullanılacak.
Devam etmek istiyor musunuz? [E/h] e
Ayarlanıyor: grub-efi-amd64 (2.02+dfsg1-4) ...
Installing for x86_64-efi platform.
Kurulum tamamlandı. Hata bildirilmedi.
Grub yapılandırma dosyası oluşturuluyor ...
Found background image: /usr/share/images/desktop-base/desktop-grub.png
Bulunan linux kalıbı: /boot/vmlinuz-4.15.0-kali2-amd64
Bulunan initrd kalıbı: /boot/initrd.img-4.15.0-kali2-amd64
Bulunan linux kalıbı: /boot/vmlinuz-4.14.0-kali3-amd64
Bulunan initrd kalıbı: /boot/initrd.img-4.14.0-kali3-amd64
dpkg: grub-efi-amd64 paketi işlenirken sorun yaşandı (--configure):
 installed grub-efi-amd64 package post-installation script subprocess returned error exit status 1
Ayarlanıyor: linux-image-4.15.0-kali2-amd64 (4.15.11-1kali1) ...
/etc/kernel/postinst.d/initramfs-tools:
update-initramfs: Generating /boot/initrd.img-4.15.0-kali2-amd64
WARNING: Setting CRYPTSETUP in /etc/initramfs-tools/initramfs.conf is deprecated and will stop working in the future. Use /etc/cryptsetup-initramfs/conf-hook instead.
/etc/kernel/postinst.d/zz-update-grub:
Grub yapılandırma dosyası oluşturuluyor ...
Found background image: /usr/share/images/desktop-base/desktop-grub.png
Bulunan linux kalıbı: /boot/vmlinuz-4.15.0-kali2-amd64
Bulunan initrd kalıbı: /boot/initrd.img-4.15.0-kali2-amd64
Bulunan linux kalıbı: /boot/vmlinuz-4.14.0-kali3-amd64
Bulunan initrd kalıbı: /boot/initrd.img-4.14.0-kali3-amd64
run-parts: /etc/kernel/postinst.d/zz-update-grub exited with return code 1
dpkg: linux-image-4.15.0-kali2-amd64 paketi işlenirken sorun yaşandı (--configure):
 installed linux-image-4.15.0-kali2-amd64 package post-installation script subprocess returned error exit status 1
dpkg: bağımlılık sorunları yüzünden linux-image-amd64 paketi yapılandırılamıyor:
 linux-image-amd64 şuna bağımlı: linux-image-4.15.0-kali2-amd64, ama:
  linux-image-4.15.0-kali2-amd64 paketi henüz yapılandırılmadı.

dpkg: linux-image-amd64 paketi işlenirken sorun yaşandı (--configure):
 bağımlılık sorunları - yapılandırılmadan bırakılıyor
İşleme sırasında hatalarla karşılaşıldı:
 grub-efi-amd64
 linux-image-4.15.0-kali2-amd64
 linux-image-amd64
E: Sub-process /usr/bin/dpkg returned an error code (1)

---- Mesajlar birleştirildi ----

demek grub-efi-amd64 den dolayı :D boot repair hata veriyodu sanırım :D ilk başta bahsettiğim konuda :)

---- Mesajlar birleştirildi ----

değil mi hocam
 
Son düzenleme:

Q_sySZero

Asistan
Katılım
7 Nisan 2018
Mesajlar
120
Reaksiyon puanı
7
Puanları
18
Yaş
21
Kod:
root@kali:~# apt install -f
Paket listeleri okunuyor... Bitti
Bağımlılık ağacı oluşturuluyor       
Durum bilgisi okunuyor... Bitti     
Aşağıdaki paketler otomatik olarak kurulmuş ve artık bu paketlere gerek duyulmuyor:
  gir1.2-mutter-1 gir1.2-networkmanager-1.0 gir1.2-nmgtk-1.0
  gnome-themes-standard keepnote libchamplain-0.12-0 libcharls1
  libdigest-md5-file-perl libdns169 libfabric1 libfreerdp-cache1.1
  libfreerdp-client1.1 libfreerdp-codec1.1 libfreerdp-common1.1.0
  libfreerdp-core1.1 libfreerdp-crypto1.1 libfreerdp-gdi1.1
  libfreerdp-locale1.1 libfreerdp-primitives1.1 libfreerdp-utils1.1
  libgcr-3-common libgdcm2.8 libgl2ps1.4 libgnome-desktop-3-12 libgweather-3-6
  libhdf5-openmpi-100 libhttp-server-simple-perl libisc166 libjs-excanvas
  liblept5 libmagickcore-6.q16-3 libmagickcore-6.q16-3-extra
  libmagickwand-6.q16-3 libmpfr4 libmutter-1-0 libnetcdf-c++4 libnm-glib4
  libnm-gtk0 libnm-util2 libopencv-calib3d3.2 libopencv-contrib3.2
  libopencv-core3.2 libopencv-features2d3.2 libopencv-flann3.2
  libopencv-highgui3.2 libopencv-imgcodecs3.2 libopencv-imgproc3.2
  libopencv-ml3.2 libopencv-objdetect3.2 libopencv-photo3.2 libopencv-shape3.2
  libopencv-stitching3.2 libopencv-superres3.2 libopencv-video3.2
  libopencv-videoio3.2 libopencv-videostab3.2 libopencv-viz3.2 libopenexr22
  libopenmpi2 libpoppler68 libpoppler72 libproj12 libpsm-infinipath1
  libqgis-analysis2.14.21 libqgis-core2.14.21 libqgis-gui2.14.21
  libqgis-networkanalysis2.14.21 libqgis-server2.14.21 libqgispython2.14.21
  libqwt5-qt4 libradare2-2.1 libruby2.3 libsocket++1 libsrtp0 libtbb2
  libtesseract4 libtxc-dxtn-s2tc libvpx4 libvtk6.3 libwinpr-crt0.1
  libwinpr-crypto0.1 libwinpr-dsparse0.1 libwinpr-environment0.1
  libwinpr-file0.1 libwinpr-handle0.1 libwinpr-heap0.1 libwinpr-input0.1
  libwinpr-interlocked0.1 libwinpr-library0.1 libwinpr-path0.1
  libwinpr-pool0.1 libwinpr-registry0.1 libwinpr-rpc0.1 libwinpr-sspi0.1
  libwinpr-synch0.1 libwinpr-sysinfo0.1 libwinpr-thread0.1 libwinpr-utils0.1
  libwww-mechanize-perl libx264-148 libxfont1 multiarch-support openjdk-8-jdk
  openjdk-8-jdk-headless openmpi-bin openmpi-common php7.0-mysql
  python-functools32 python-httpretty python3-construct python3-cssutils
  python3-feedparser python3-html2text readpst ruby2.3 ruby2.3-dev sbsigntool
  vino
Bu paketleri kaldırmak için 'apt autoremove' komutunu kullanın.
0 paket yükseltilecek, 0 yeni paket kurulacak, 0 paket kaldırılacak ve 0 paket yükseltilmeyecek.
3 paket tam olarak kurulmayacak ya da kaldırılmayacak.
Bu işlem tamamlandıktan sonra 0 B ek disk alanı kullanılacak.
Ayarlanıyor: grub-efi-amd64 (2.02+dfsg1-4) ...
Installing for x86_64-efi platform.
Kurulum tamamlandı. Hata bildirilmedi.
Grub yapılandırma dosyası oluşturuluyor ...
Found background image: /usr/share/images/desktop-base/desktop-grub.png
Bulunan linux kalıbı: /boot/vmlinuz-4.15.0-kali2-amd64
Bulunan initrd kalıbı: /boot/initrd.img-4.15.0-kali2-amd64
Bulunan linux kalıbı: /boot/vmlinuz-4.14.0-kali3-amd64
Bulunan initrd kalıbı: /boot/initrd.img-4.14.0-kali3-amd64
dpkg: grub-efi-amd64 paketi işlenirken sorun yaşandı (--configure):
 installed grub-efi-amd64 package post-installation script subprocess returned error exit status 1
Ayarlanıyor: linux-image-4.15.0-kali2-amd64 (4.15.11-1kali1) ...
/etc/kernel/postinst.d/initramfs-tools:
update-initramfs: Generating /boot/initrd.img-4.15.0-kali2-amd64
WARNING: Setting CRYPTSETUP in /etc/initramfs-tools/initramfs.conf is deprecated and will stop working in the future. Use /etc/cryptsetup-initramfs/conf-hook instead.
/etc/kernel/postinst.d/zz-update-grub:
Grub yapılandırma dosyası oluşturuluyor ...
Found background image: /usr/share/images/desktop-base/desktop-grub.png
Bulunan linux kalıbı: /boot/vmlinuz-4.15.0-kali2-amd64
Bulunan initrd kalıbı: /boot/initrd.img-4.15.0-kali2-amd64
Bulunan linux kalıbı: /boot/vmlinuz-4.14.0-kali3-amd64
Bulunan initrd kalıbı: /boot/initrd.img-4.14.0-kali3-amd64
run-parts: /etc/kernel/postinst.d/zz-update-grub exited with return code 1
dpkg: linux-image-4.15.0-kali2-amd64 paketi işlenirken sorun yaşandı (--configure):
 installed linux-image-4.15.0-kali2-amd64 package post-installation script subprocess returned error exit status 1
dpkg: bağımlılık sorunları yüzünden linux-image-amd64 paketi yapılandırılamıyor:
 linux-image-amd64 şuna bağımlı: linux-image-4.15.0-kali2-amd64, ama:
  linux-image-4.15.0-kali2-amd64 paketi henüz yapılandırılmadı.

dpkg: linux-image-amd64 paketi işlenirken sorun yaşandı (--configure):
 bağımlılık sorunları - yapılandırılmadan bırakılıyor
İşleme sırasında hatalarla karşılaşıldı:
 grub-efi-amd64
 linux-image-4.15.0-kali2-amd64
 linux-image-amd64
E: Sub-process /usr/bin/dpkg returned an error code (1)
 

Hopeツ︎

Profesör
Emektar
Katılım
9 Mart 2016
Mesajlar
1,851
Çözümler
1
Reaksiyon puanı
1,892
Puanları
113
Yaş
24
Amacım insanlarımn bilgilerini çalmak değil kendimi bilişim güvenliği konusunda geliştirmek istiyorum :D tabi bu dediklerim sizi tatmin etmez ama ona bakarsanız her evde bıçak var herkes katil mi :)
Herkesin amacının Kali Linux kullanırken bu olduğuna canı gönülden inanabilsek ve inandığımız gibi sahidende durum böyle olsa zaten ortada bir problem kalmayacak. Bu tamamen kişinin niyeti ve düşüncesi ile alakalı, White hat arkadaşlarımızı bu teorinin gerisinde tutuyoruz. Kali Linux'u Black hat olarak kullananları esas alıyor benim söylediklerim. Yanlış anlaşılma olmasın... :)
 

Q_sySZero

Asistan
Katılım
7 Nisan 2018
Mesajlar
120
Reaksiyon puanı
7
Puanları
18
Yaş
21
Herkesin amacının Kali Linux kullanırken bu olduğuna canı gönülden inanabilsek ve inandığımız gibi sahidende durum böyle olsa zaten ortada bir problem kalmayacak. Bu tamamen kişinin niyeti ve düşüncesi ile alakalı, White hat arkadaşlarımızı bu teorinin gerisinde tutuyoruz. Kali Linux'u Black hat olarak kullananları esas alıyor benim söylediklerim. Yanlış anlaşılma olmasın... :)
yukarıda attığım hata ile ilgli bir :D öneriniz varmı nasıl çözebileceğime dair
 

Q_sySZero

Asistan
Katılım
7 Nisan 2018
Mesajlar
120
Reaksiyon puanı
7
Puanları
18
Yaş
21
Kod:
root@kali:~# apt autoremove
Paket listeleri okunuyor... Bitti
Bağımlılık ağacı oluşturuluyor       
Durum bilgisi okunuyor... Bitti     
Aşağıdaki paketler KALDIRILACAK:
  gir1.2-mutter-1 gir1.2-networkmanager-1.0 gir1.2-nmgtk-1.0
  gnome-themes-standard keepnote libchamplain-0.12-0 libcharls1
  libdigest-md5-file-perl libdns169 libfabric1 libfreerdp-cache1.1
  libfreerdp-client1.1 libfreerdp-codec1.1 libfreerdp-common1.1.0
  libfreerdp-core1.1 libfreerdp-crypto1.1 libfreerdp-gdi1.1
  libfreerdp-locale1.1 libfreerdp-primitives1.1 libfreerdp-utils1.1
  libgcr-3-common libgdcm2.8 libgl2ps1.4 libgnome-desktop-3-12 libgweather-3-6
  libhdf5-openmpi-100 libhttp-server-simple-perl libisc166 libjs-excanvas
  liblept5 libmagickcore-6.q16-3 libmagickcore-6.q16-3-extra
  libmagickwand-6.q16-3 libmpfr4 libmutter-1-0 libnetcdf-c++4 libnm-glib4
  libnm-gtk0 libnm-util2 libopencv-calib3d3.2 libopencv-contrib3.2
  libopencv-core3.2 libopencv-features2d3.2 libopencv-flann3.2
  libopencv-highgui3.2 libopencv-imgcodecs3.2 libopencv-imgproc3.2
  libopencv-ml3.2 libopencv-objdetect3.2 libopencv-photo3.2 libopencv-shape3.2
  libopencv-stitching3.2 libopencv-superres3.2 libopencv-video3.2
  libopencv-videoio3.2 libopencv-videostab3.2 libopencv-viz3.2 libopenexr22
  libopenmpi2 libpoppler68 libpoppler72 libproj12 libpsm-infinipath1
  libqgis-analysis2.14.21 libqgis-core2.14.21 libqgis-gui2.14.21
  libqgis-networkanalysis2.14.21 libqgis-server2.14.21 libqgispython2.14.21
  libqwt5-qt4 libradare2-2.1 libruby2.3 libsocket++1 libsrtp0 libtbb2
  libtesseract4 libtxc-dxtn-s2tc libvpx4 libvtk6.3 libwinpr-crt0.1
  libwinpr-crypto0.1 libwinpr-dsparse0.1 libwinpr-environment0.1
  libwinpr-file0.1 libwinpr-handle0.1 libwinpr-heap0.1 libwinpr-input0.1
  libwinpr-interlocked0.1 libwinpr-library0.1 libwinpr-path0.1
  libwinpr-pool0.1 libwinpr-registry0.1 libwinpr-rpc0.1 libwinpr-sspi0.1
  libwinpr-synch0.1 libwinpr-sysinfo0.1 libwinpr-thread0.1 libwinpr-utils0.1
  libwww-mechanize-perl libx264-148 libxfont1 multiarch-support openjdk-8-jdk
  openjdk-8-jdk-headless openmpi-bin openmpi-common php7.0-mysql
  python-functools32 python-httpretty python3-construct python3-cssutils
  python3-feedparser python3-html2text readpst ruby2.3 ruby2.3-dev sbsigntool
  vino
0 paket yükseltilecek, 0 yeni paket kurulacak, 118 paket kaldırılacak ve 0 paket yükseltilmeyecek.
3 paket tam olarak kurulmayacak ya da kaldırılmayacak.
Bu işlem tamamlandıktan sonra 359 MB disk alanı boşalacak.
Devam etmek istiyor musunuz? [E/h] e
(Veritabanı okunuyor ... 346849 dosya veya dizin kurulu durumda.)
Kaldırılıyor: gir1.2-mutter-1:amd64 (3.26.2-1) ...
Kaldırılıyor: gir1.2-nmgtk-1.0:amd64 (1.8.10-2) ...
Kaldırılıyor: gir1.2-networkmanager-1.0:amd64 (1.10.6-2) ...
Kaldırılıyor: gnome-themes-standard (3.28-1) ...
Kaldırılıyor: keepnote (0.7.8-1.1) ...
Kaldırılıyor: libchamplain-0.12-0:amd64 (0.12.16-2) ...
Kaldırılıyor: libopencv-contrib3.2:amd64 (3.2.0+dfsg-4+b4) ...
Kaldırılıyor: libopencv-videostab3.2:amd64 (3.2.0+dfsg-4+b4) ...
Kaldırılıyor: libdigest-md5-file-perl (0.08-1) ...
Kaldırılıyor: libdns169:amd64 (1:9.11.2.P1-1) ...
Kaldırılıyor: openmpi-bin (2.1.1-8) ...
Kaldırılıyor: libopencv-viz3.2:amd64 (3.2.0+dfsg-4+b4) ...
Kaldırılıyor: libvtk6.3 (6.3.0+dfsg2-2) ...
Kaldırılıyor: libfreerdp-gdi1.1:amd64 (1.1.0~git20140921.1.440916e+dfsg1-15) ...
Kaldırılıyor: libfreerdp-cache1.1:amd64 (1.1.0~git20140921.1.440916e+dfsg1-15) ...
Kaldırılıyor: libfreerdp-client1.1:amd64 (1.1.0~git20140921.1.440916e+dfsg1-15) ...
Kaldırılıyor: libfreerdp-core1.1:amd64 (1.1.0~git20140921.1.440916e+dfsg1-15) ...
Kaldırılıyor: libfreerdp-codec1.1:amd64 (1.1.0~git20140921.1.440916e+dfsg1-15) ...
Kaldırılıyor: libfreerdp-common1.1.0:amd64 (1.1.0~git20140921.1.440916e+dfsg1-15) ...
Kaldırılıyor: libfreerdp-crypto1.1:amd64 (1.1.0~git20140921.1.440916e+dfsg1-15) ...
Kaldırılıyor: libfreerdp-locale1.1:amd64 (1.1.0~git20140921.1.440916e+dfsg1-15) ...
Kaldırılıyor: libfreerdp-primitives1.1:amd64 (1.1.0~git20140921.1.440916e+dfsg1-15) ...
Kaldırılıyor: libfreerdp-utils1.1:amd64 (1.1.0~git20140921.1.440916e+dfsg1-15) ...
Kaldırılıyor: libgcr-3-common (3.20.0-6) ...
Kaldırılıyor: libgl2ps1.4 (1.4.0+dfsg1-2) ...
Kaldırılıyor: libmutter-1-0:amd64 (3.26.2-1) ...
Kaldırılıyor: libgnome-desktop-3-12:amd64 (3.26.2-4) ...
Kaldırılıyor: libgweather-3-6:amd64 (3.26.1-2) ...
Kaldırılıyor: libhdf5-openmpi-100:amd64 (1.10.0-patch1+docs-4) ...
Kaldırılıyor: libwww-mechanize-perl (1.86-1) ...
Kaldırılıyor: libhttp-server-simple-perl (0.52-1) ...
Kaldırılıyor: libisc166:amd64 (1:9.11.2.P1-1) ...
Kaldırılıyor: libjs-excanvas (0.r3-4) ...
Kaldırılıyor: libtesseract4 (4.00~git2219-40f43111-1.2) ...
Kaldırılıyor: liblept5 (1.75.3-3) ...
Kaldırılıyor: libmagickcore-6.q16-3-extra:amd64 (8:6.9.7.4+dfsg-16) ...
Kaldırılıyor: libmagickwand-6.q16-3:amd64 (8:6.9.7.4+dfsg-16) ...
Kaldırılıyor: libmagickcore-6.q16-3:amd64 (8:6.9.7.4+dfsg-16) ...
Kaldırılıyor: libmpfr4:amd64 (3.1.6-1) ...
Kaldırılıyor: libnetcdf-c++4 (4.2-8) ...
Kaldırılıyor: libnm-gtk0:amd64 (1.8.10-2) ...
Kaldırılıyor: libnm-glib4:amd64 (1.10.6-2) ...
Kaldırılıyor: libnm-util2:amd64 (1.10.6-2) ...
Kaldırılıyor: libopencv-stitching3.2:amd64 (3.2.0+dfsg-4+b4) ...
Kaldırılıyor: libopencv-calib3d3.2:amd64 (3.2.0+dfsg-4+b4) ...
Kaldırılıyor: libopencv-superres3.2:amd64 (3.2.0+dfsg-4+b4) ...
Kaldırılıyor: libopencv-objdetect3.2:amd64 (3.2.0+dfsg-4+b4) ...
Kaldırılıyor: libopencv-shape3.2:amd64 (3.2.0+dfsg-4+b4) ...
Kaldırılıyor: libopencv-video3.2:amd64 (3.2.0+dfsg-4+b4) ...
Kaldırılıyor: libopencv-features2d3.2:amd64 (3.2.0+dfsg-4+b4) ...
Kaldırılıyor: libopencv-flann3.2:amd64 (3.2.0+dfsg-4+b4) ...
Kaldırılıyor: libopencv-highgui3.2:amd64 (3.2.0+dfsg-4+b4) ...
Kaldırılıyor: libopencv-photo3.2:amd64 (3.2.0+dfsg-4+b4) ...
Kaldırılıyor: libopencv-ml3.2:amd64 (3.2.0+dfsg-4+b4) ...
Kaldırılıyor: libopenexr22:amd64 (2.2.0-11.1+b1) ...
Kaldırılıyor: libpoppler68:amd64 (0.57.0-2) ...
Kaldırılıyor: libpoppler72:amd64 (0.61.1-2) ...
Kaldırılıyor: libqgis-server2.14.21 (2.14.21+dfsg-3) ...
Kaldırılıyor: libqgis-gui2.14.21 (2.14.21+dfsg-3) ...
Kaldırılıyor: libqgis-analysis2.14.21 (2.14.21+dfsg-3) ...
Kaldırılıyor: libqgispython2.14.21 (2.14.21+dfsg-3) ...
Kaldırılıyor: libqgis-networkanalysis2.14.21 (2.14.21+dfsg-3) ...
Kaldırılıyor: libqwt5-qt4 (5.2.3-1) ...
Kaldırılıyor: libradare2-2.1:amd64 (2.1.0+dfsg-1) ...
Kaldırılıyor: ruby2.3-dev:amd64 (2.3.6-2) ...
Kaldırılıyor: ruby2.3 (2.3.6-2) ...
Kaldırılıyor: libruby2.3:amd64 (2.3.6-2) ...
Kaldırılıyor: libsrtp0 (1.4.5~20130609~dfsg-2) ...
Kaldırılıyor: libtxc-dxtn-s2tc:amd64 (1.0+git20151227-2) ...
Kaldırılıyor: libvpx4:amd64 (1.6.1-3) ...
Kaldırılıyor: libwinpr-sspi0.1:amd64 (1.1.0~git20140921.1.440916e+dfsg1-15) ...
Kaldırılıyor: libwinpr-registry0.1:amd64 (1.1.0~git20140921.1.440916e+dfsg1-15) ...
Kaldırılıyor: libwinpr-pool0.1:amd64 (1.1.0~git20140921.1.440916e+dfsg1-15) ...
Kaldırılıyor: libwinpr-crypto0.1:amd64 (1.1.0~git20140921.1.440916e+dfsg1-15) ...
Kaldırılıyor: libwinpr-dsparse0.1:amd64 (1.1.0~git20140921.1.440916e+dfsg1-15) ...
Kaldırılıyor: libwinpr-path0.1:amd64 (1.1.0~git20140921.1.440916e+dfsg1-15) ...
Kaldırılıyor: libwinpr-environment0.1:amd64 (1.1.0~git20140921.1.440916e+dfsg1-15) ...
Kaldırılıyor: libwinpr-file0.1:amd64 (1.1.0~git20140921.1.440916e+dfsg1-15) ...
Kaldırılıyor: libwinpr-heap0.1:amd64 (1.1.0~git20140921.1.440916e+dfsg1-15) ...
Kaldırılıyor: libwinpr-input0.1:amd64 (1.1.0~git20140921.1.440916e+dfsg1-15) ...
Kaldırılıyor: libwinpr-library0.1:amd64 (1.1.0~git20140921.1.440916e+dfsg1-15) ...
Kaldırılıyor: libwinpr-rpc0.1:amd64 (1.1.0~git20140921.1.440916e+dfsg1-15) ...
Kaldırılıyor: libx264-148:amd64 (2:0.148.2795+gitaaa9aa8-1) ...
Kaldırılıyor: libxfont1:amd64 (1:1.5.2-4) ...
Kaldırılıyor: multiarch-support (2.27-3) ...
Kaldırılıyor: openjdk-8-jdk:amd64 (8u162-b12-1) ...
Kaldırılıyor: openjdk-8-jdk-headless:amd64 (8u162-b12-1) ...
Kaldırılıyor: openmpi-common (2.1.1-8) ...
Kaldırılıyor: php7.0-mysql (7.0.28-1) ...
Kaldırılıyor: python-functools32 (3.2.3.2-3) ...
Kaldırılıyor: python-httpretty (0.8.14-1) ...
Kaldırılıyor: python3-construct (2.8.16-0.2) ...
dpkg: uyarı: python3-construct kaldırılırken '/usr/lib/python3/dist-packages/construct/lib' dizini boş olmadığı için kaldırılmadı
dpkg: uyarı: python3-construct kaldırılırken '/usr/lib/python3/dist-packages/construct/examples/protocols' dizini boş olmadığı için kaldırılmadı
dpkg: uyarı: python3-construct kaldırılırken '/usr/lib/python3/dist-packages/construct/examples/formats/graphics' dizini boş olmadığı için kaldırılmadı
dpkg: uyarı: python3-construct kaldırılırken '/usr/lib/python3/dist-packages/construct/examples/formats/filesystem' dizini boş olmadığı için kaldırılmadı
dpkg: uyarı: python3-construct kaldırılırken '/usr/lib/python3/dist-packages/construct/examples/formats/executable' dizini boş olmadığı için kaldırılmadı
dpkg: uyarı: python3-construct kaldırılırken '/usr/lib/python3/dist-packages/construct/examples/formats/data' dizini boş olmadığı için kaldırılmadı
Kaldırılıyor: python3-cssutils (1.0.2-1) ...
dpkg: uyarı: python3-cssutils kaldırılırken '/usr/lib/python3.6/dist-packages/encutils' dizini boş olmadığı için kaldırılmadı
dpkg: uyarı: python3-cssutils kaldırılırken '/usr/lib/python3/dist-packages/encutils' dizini boş olmadığı için kaldırılmadı
dpkg: uyarı: python3-cssutils kaldırılırken '/usr/lib/python3/dist-packages/cssutils/tests/test_encutils' dizini boş olmadığı için kaldırılmadı
dpkg: uyarı: python3-cssutils kaldırılırken '/usr/lib/python3/dist-packages/cssutils/stylesheets' dizini boş olmadığı için kaldırılmadı
dpkg: uyarı: python3-cssutils kaldırılırken '/usr/lib/python3/dist-packages/cssutils/scripts' dizini boş olmadığı için kaldırılmadı
dpkg: uyarı: python3-cssutils kaldırılırken '/usr/lib/python3/dist-packages/cssutils/css' dizini boş olmadığı için kaldırılmadı
Kaldırılıyor: python3-feedparser (5.2.1-1) ...
dpkg: uyarı: python3-feedparser kaldırılırken '/usr/lib/python3/dist-packages/feedparser_debian' dizini boş olmadığı için kaldırılmadı
Kaldırılıyor: python3-html2text (2018.1.9-1) ...
Kaldırılıyor: readpst (0.6.59-1) ...
Kaldırılıyor: sbsigntool (0.6-3.2) ...
Kaldırılıyor: vino (3.22.0-3) ...
Kaldırılıyor: libopenmpi2:amd64 (2.1.1-8) ...
Kaldırılıyor: libfabric1 (1.5.3-1) ...
Kaldırılıyor: libopencv-videoio3.2:amd64 (3.2.0+dfsg-4+b4) ...
Kaldırılıyor: libpsm-infinipath1 (3.3+20.604758e7-5) ...
update-alternatives: uyarı: /usr/lib/libpsm1/libpsm_infinipath.so.1.16 alternatifi (libpsm_infinipath.so.1 bağ grubunun bir parçası) mevcut değil; alternatifler listesinden kaldırılıyor
update-alternatives: uyarı: /etc/alternatives/libpsm_infinipath.so.1 bağı kopmuş, en iyi seçenek ile güncellenecek
Kaldırılıyor: libqgis-core2.14.21 (2.14.21+dfsg-3) ...
Kaldırılıyor: libwinpr-utils0.1:amd64 (1.1.0~git20140921.1.440916e+dfsg1-15) ...
Kaldırılıyor: libwinpr-synch0.1:amd64 (1.1.0~git20140921.1.440916e+dfsg1-15) ...
Kaldırılıyor: libwinpr-thread0.1:amd64 (1.1.0~git20140921.1.440916e+dfsg1-15) ...
Kaldırılıyor: libwinpr-interlocked0.1:amd64 (1.1.0~git20140921.1.440916e+dfsg1-15) ...
Kaldırılıyor: libwinpr-handle0.1:amd64 (1.1.0~git20140921.1.440916e+dfsg1-15) ...
Kaldırılıyor: libwinpr-sysinfo0.1:amd64 (1.1.0~git20140921.1.440916e+dfsg1-15) ...
Kaldırılıyor: libopencv-imgcodecs3.2:amd64 (3.2.0+dfsg-4+b4) ...
Kaldırılıyor: libgdcm2.8:amd64 (2.8.4-1+b2) ...
Kaldırılıyor: libcharls1:amd64 (1.1.0+dfsg-2) ...
Kaldırılıyor: libopencv-imgproc3.2:amd64 (3.2.0+dfsg-4+b4) ...
Kaldırılıyor: libproj12:amd64 (4.9.3-2) ...
Kaldırılıyor: libsocket++1:amd64 (1.12.13-9) ...
Kaldırılıyor: libwinpr-crt0.1:amd64 (1.1.0~git20140921.1.440916e+dfsg1-15) ...
Kaldırılıyor: libopencv-core3.2:amd64 (3.2.0+dfsg-4+b4) ...
Kaldırılıyor: libtbb2:amd64 (2017~U7-8) ...
Ayarlanıyor: grub-efi-amd64 (2.02+dfsg1-4) ...
Installing for x86_64-efi platform.
Kurulum tamamlandı. Hata bildirilmedi.
Grub yapılandırma dosyası oluşturuluyor ...
Found background image: /usr/share/images/desktop-base/desktop-grub.png
Bulunan linux kalıbı: /boot/vmlinuz-4.15.0-kali2-amd64
Bulunan initrd kalıbı: /boot/initrd.img-4.15.0-kali2-amd64
Bulunan linux kalıbı: /boot/vmlinuz-4.14.0-kali3-amd64
Bulunan initrd kalıbı: /boot/initrd.img-4.14.0-kali3-amd64
dpkg: grub-efi-amd64 paketi işlenirken sorun yaşandı (--configure):
 installed grub-efi-amd64 package post-installation script subprocess returned error exit status 1
Tetikleyiciler işleniyor: mime-support (3.60) ...
Tetikleyiciler işleniyor: desktop-file-utils (0.23-3) ...
Tetikleyiciler işleniyor: libapache2-mod-php7.0 (7.0.28-1) ...
Tetikleyiciler işleniyor: libglib2.0-0:amd64 (2.56.0-4) ...
Ayarlanıyor: linux-image-4.15.0-kali2-amd64 (4.15.11-1kali1) ...
/etc/kernel/postinst.d/initramfs-tools:
update-initramfs: Generating /boot/initrd.img-4.15.0-kali2-amd64
WARNING: Setting CRYPTSETUP in /etc/initramfs-tools/initramfs.conf is deprecated and will stop working in the future. Use /etc/cryptsetup-initramfs/conf-hook instead.
/etc/kernel/postinst.d/zz-update-grub:
Grub yapılandırma dosyası oluşturuluyor ...
Found background image: /usr/share/images/desktop-base/desktop-grub.png
Bulunan linux kalıbı: /boot/vmlinuz-4.15.0-kali2-amd64
Bulunan initrd kalıbı: /boot/initrd.img-4.15.0-kali2-amd64
Bulunan linux kalıbı: /boot/vmlinuz-4.14.0-kali3-amd64
Bulunan initrd kalıbı: /boot/initrd.img-4.14.0-kali3-amd64
run-parts: /etc/kernel/postinst.d/zz-update-grub exited with return code 1
dpkg: linux-image-4.15.0-kali2-amd64 paketi işlenirken sorun yaşandı (--configure):
 installed linux-image-4.15.0-kali2-amd64 package post-installation script subprocess returned error exit status 1
dpkg: bağımlılık sorunları yüzünden linux-image-amd64 paketi yapılandırılamıyor:
 linux-image-amd64 şuna bağımlı: linux-image-4.15.0-kali2-amd64, ama:
  linux-image-4.15.0-kali2-amd64 paketi henüz yapılandırılmadı.

dpkg: linux-image-amd64 paketi işlenirken sorun yaşandı (--configure):
 bağımlılık sorunları - yapılandırılmadan bırakılıyor
Tetikleyiciler işleniyor: libc-bin (2.27-3) ...
Tetikleyiciler işleniyor: man-db (2.8.2-1) ...
Tetikleyiciler işleniyor: gnome-menus (3.13.3-11) ...
Tetikleyiciler işleniyor: hicolor-icon-theme (0.17-2) ...
İşleme sırasında hatalarla karşılaşıldı:
 grub-efi-amd64
 linux-image-4.15.0-kali2-amd64
 linux-image-amd64
E: Sub-process /usr/bin/dpkg returned an error code (1)
 

Hopeツ︎

Profesör
Emektar
Katılım
9 Mart 2016
Mesajlar
1,851
Çözümler
1
Reaksiyon puanı
1,892
Puanları
113
Yaş
24
Kod:
root@kali:~# apt autoremove
Paket listeleri okunuyor... Bitti
Bağımlılık ağacı oluşturuluyor     
Durum bilgisi okunuyor... Bitti   
Aşağıdaki paketler KALDIRILACAK:
  gir1.2-mutter-1 gir1.2-networkmanager-1.0 gir1.2-nmgtk-1.0
  gnome-themes-standard keepnote libchamplain-0.12-0 libcharls1
  libdigest-md5-file-perl libdns169 libfabric1 libfreerdp-cache1.1
  libfreerdp-client1.1 libfreerdp-codec1.1 libfreerdp-common1.1.0
  libfreerdp-core1.1 libfreerdp-crypto1.1 libfreerdp-gdi1.1
  libfreerdp-locale1.1 libfreerdp-primitives1.1 libfreerdp-utils1.1
  libgcr-3-common libgdcm2.8 libgl2ps1.4 libgnome-desktop-3-12 libgweather-3-6
  libhdf5-openmpi-100 libhttp-server-simple-perl libisc166 libjs-excanvas
  liblept5 libmagickcore-6.q16-3 libmagickcore-6.q16-3-extra
  libmagickwand-6.q16-3 libmpfr4 libmutter-1-0 libnetcdf-c++4 libnm-glib4
  libnm-gtk0 libnm-util2 libopencv-calib3d3.2 libopencv-contrib3.2
  libopencv-core3.2 libopencv-features2d3.2 libopencv-flann3.2
  libopencv-highgui3.2 libopencv-imgcodecs3.2 libopencv-imgproc3.2
  libopencv-ml3.2 libopencv-objdetect3.2 libopencv-photo3.2 libopencv-shape3.2
  libopencv-stitching3.2 libopencv-superres3.2 libopencv-video3.2
  libopencv-videoio3.2 libopencv-videostab3.2 libopencv-viz3.2 libopenexr22
  libopenmpi2 libpoppler68 libpoppler72 libproj12 libpsm-infinipath1
  libqgis-analysis2.14.21 libqgis-core2.14.21 libqgis-gui2.14.21
  libqgis-networkanalysis2.14.21 libqgis-server2.14.21 libqgispython2.14.21
  libqwt5-qt4 libradare2-2.1 libruby2.3 libsocket++1 libsrtp0 libtbb2
  libtesseract4 libtxc-dxtn-s2tc libvpx4 libvtk6.3 libwinpr-crt0.1
  libwinpr-crypto0.1 libwinpr-dsparse0.1 libwinpr-environment0.1
  libwinpr-file0.1 libwinpr-handle0.1 libwinpr-heap0.1 libwinpr-input0.1
  libwinpr-interlocked0.1 libwinpr-library0.1 libwinpr-path0.1
  libwinpr-pool0.1 libwinpr-registry0.1 libwinpr-rpc0.1 libwinpr-sspi0.1
  libwinpr-synch0.1 libwinpr-sysinfo0.1 libwinpr-thread0.1 libwinpr-utils0.1
  libwww-mechanize-perl libx264-148 libxfont1 multiarch-support openjdk-8-jdk
  openjdk-8-jdk-headless openmpi-bin openmpi-common php7.0-mysql
  python-functools32 python-httpretty python3-construct python3-cssutils
  python3-feedparser python3-html2text readpst ruby2.3 ruby2.3-dev sbsigntool
  vino
0 paket yükseltilecek, 0 yeni paket kurulacak, 118 paket kaldırılacak ve 0 paket yükseltilmeyecek.
3 paket tam olarak kurulmayacak ya da kaldırılmayacak.
Bu işlem tamamlandıktan sonra 359 MB disk alanı boşalacak.
Devam etmek istiyor musunuz? [E/h] e
(Veritabanı okunuyor ... 346849 dosya veya dizin kurulu durumda.)
Kaldırılıyor: gir1.2-mutter-1:amd64 (3.26.2-1) ...
Kaldırılıyor: gir1.2-nmgtk-1.0:amd64 (1.8.10-2) ...
Kaldırılıyor: gir1.2-networkmanager-1.0:amd64 (1.10.6-2) ...
Kaldırılıyor: gnome-themes-standard (3.28-1) ...
Kaldırılıyor: keepnote (0.7.8-1.1) ...
Kaldırılıyor: libchamplain-0.12-0:amd64 (0.12.16-2) ...
Kaldırılıyor: libopencv-contrib3.2:amd64 (3.2.0+dfsg-4+b4) ...
Kaldırılıyor: libopencv-videostab3.2:amd64 (3.2.0+dfsg-4+b4) ...
Kaldırılıyor: libdigest-md5-file-perl (0.08-1) ...
Kaldırılıyor: libdns169:amd64 (1:9.11.2.P1-1) ...
Kaldırılıyor: openmpi-bin (2.1.1-8) ...
Kaldırılıyor: libopencv-viz3.2:amd64 (3.2.0+dfsg-4+b4) ...
Kaldırılıyor: libvtk6.3 (6.3.0+dfsg2-2) ...
Kaldırılıyor: libfreerdp-gdi1.1:amd64 (1.1.0~git20140921.1.440916e+dfsg1-15) ...
Kaldırılıyor: libfreerdp-cache1.1:amd64 (1.1.0~git20140921.1.440916e+dfsg1-15) ...
Kaldırılıyor: libfreerdp-client1.1:amd64 (1.1.0~git20140921.1.440916e+dfsg1-15) ...
Kaldırılıyor: libfreerdp-core1.1:amd64 (1.1.0~git20140921.1.440916e+dfsg1-15) ...
Kaldırılıyor: libfreerdp-codec1.1:amd64 (1.1.0~git20140921.1.440916e+dfsg1-15) ...
Kaldırılıyor: libfreerdp-common1.1.0:amd64 (1.1.0~git20140921.1.440916e+dfsg1-15) ...
Kaldırılıyor: libfreerdp-crypto1.1:amd64 (1.1.0~git20140921.1.440916e+dfsg1-15) ...
Kaldırılıyor: libfreerdp-locale1.1:amd64 (1.1.0~git20140921.1.440916e+dfsg1-15) ...
Kaldırılıyor: libfreerdp-primitives1.1:amd64 (1.1.0~git20140921.1.440916e+dfsg1-15) ...
Kaldırılıyor: libfreerdp-utils1.1:amd64 (1.1.0~git20140921.1.440916e+dfsg1-15) ...
Kaldırılıyor: libgcr-3-common (3.20.0-6) ...
Kaldırılıyor: libgl2ps1.4 (1.4.0+dfsg1-2) ...
Kaldırılıyor: libmutter-1-0:amd64 (3.26.2-1) ...
Kaldırılıyor: libgnome-desktop-3-12:amd64 (3.26.2-4) ...
Kaldırılıyor: libgweather-3-6:amd64 (3.26.1-2) ...
Kaldırılıyor: libhdf5-openmpi-100:amd64 (1.10.0-patch1+docs-4) ...
Kaldırılıyor: libwww-mechanize-perl (1.86-1) ...
Kaldırılıyor: libhttp-server-simple-perl (0.52-1) ...
Kaldırılıyor: libisc166:amd64 (1:9.11.2.P1-1) ...
Kaldırılıyor: libjs-excanvas (0.r3-4) ...
Kaldırılıyor: libtesseract4 (4.00~git2219-40f43111-1.2) ...
Kaldırılıyor: liblept5 (1.75.3-3) ...
Kaldırılıyor: libmagickcore-6.q16-3-extra:amd64 (8:6.9.7.4+dfsg-16) ...
Kaldırılıyor: libmagickwand-6.q16-3:amd64 (8:6.9.7.4+dfsg-16) ...
Kaldırılıyor: libmagickcore-6.q16-3:amd64 (8:6.9.7.4+dfsg-16) ...
Kaldırılıyor: libmpfr4:amd64 (3.1.6-1) ...
Kaldırılıyor: libnetcdf-c++4 (4.2-8) ...
Kaldırılıyor: libnm-gtk0:amd64 (1.8.10-2) ...
Kaldırılıyor: libnm-glib4:amd64 (1.10.6-2) ...
Kaldırılıyor: libnm-util2:amd64 (1.10.6-2) ...
Kaldırılıyor: libopencv-stitching3.2:amd64 (3.2.0+dfsg-4+b4) ...
Kaldırılıyor: libopencv-calib3d3.2:amd64 (3.2.0+dfsg-4+b4) ...
Kaldırılıyor: libopencv-superres3.2:amd64 (3.2.0+dfsg-4+b4) ...
Kaldırılıyor: libopencv-objdetect3.2:amd64 (3.2.0+dfsg-4+b4) ...
Kaldırılıyor: libopencv-shape3.2:amd64 (3.2.0+dfsg-4+b4) ...
Kaldırılıyor: libopencv-video3.2:amd64 (3.2.0+dfsg-4+b4) ...
Kaldırılıyor: libopencv-features2d3.2:amd64 (3.2.0+dfsg-4+b4) ...
Kaldırılıyor: libopencv-flann3.2:amd64 (3.2.0+dfsg-4+b4) ...
Kaldırılıyor: libopencv-highgui3.2:amd64 (3.2.0+dfsg-4+b4) ...
Kaldırılıyor: libopencv-photo3.2:amd64 (3.2.0+dfsg-4+b4) ...
Kaldırılıyor: libopencv-ml3.2:amd64 (3.2.0+dfsg-4+b4) ...
Kaldırılıyor: libopenexr22:amd64 (2.2.0-11.1+b1) ...
Kaldırılıyor: libpoppler68:amd64 (0.57.0-2) ...
Kaldırılıyor: libpoppler72:amd64 (0.61.1-2) ...
Kaldırılıyor: libqgis-server2.14.21 (2.14.21+dfsg-3) ...
Kaldırılıyor: libqgis-gui2.14.21 (2.14.21+dfsg-3) ...
Kaldırılıyor: libqgis-analysis2.14.21 (2.14.21+dfsg-3) ...
Kaldırılıyor: libqgispython2.14.21 (2.14.21+dfsg-3) ...
Kaldırılıyor: libqgis-networkanalysis2.14.21 (2.14.21+dfsg-3) ...
Kaldırılıyor: libqwt5-qt4 (5.2.3-1) ...
Kaldırılıyor: libradare2-2.1:amd64 (2.1.0+dfsg-1) ...
Kaldırılıyor: ruby2.3-dev:amd64 (2.3.6-2) ...
Kaldırılıyor: ruby2.3 (2.3.6-2) ...
Kaldırılıyor: libruby2.3:amd64 (2.3.6-2) ...
Kaldırılıyor: libsrtp0 (1.4.5~20130609~dfsg-2) ...
Kaldırılıyor: libtxc-dxtn-s2tc:amd64 (1.0+git20151227-2) ...
Kaldırılıyor: libvpx4:amd64 (1.6.1-3) ...
Kaldırılıyor: libwinpr-sspi0.1:amd64 (1.1.0~git20140921.1.440916e+dfsg1-15) ...
Kaldırılıyor: libwinpr-registry0.1:amd64 (1.1.0~git20140921.1.440916e+dfsg1-15) ...
Kaldırılıyor: libwinpr-pool0.1:amd64 (1.1.0~git20140921.1.440916e+dfsg1-15) ...
Kaldırılıyor: libwinpr-crypto0.1:amd64 (1.1.0~git20140921.1.440916e+dfsg1-15) ...
Kaldırılıyor: libwinpr-dsparse0.1:amd64 (1.1.0~git20140921.1.440916e+dfsg1-15) ...
Kaldırılıyor: libwinpr-path0.1:amd64 (1.1.0~git20140921.1.440916e+dfsg1-15) ...
Kaldırılıyor: libwinpr-environment0.1:amd64 (1.1.0~git20140921.1.440916e+dfsg1-15) ...
Kaldırılıyor: libwinpr-file0.1:amd64 (1.1.0~git20140921.1.440916e+dfsg1-15) ...
Kaldırılıyor: libwinpr-heap0.1:amd64 (1.1.0~git20140921.1.440916e+dfsg1-15) ...
Kaldırılıyor: libwinpr-input0.1:amd64 (1.1.0~git20140921.1.440916e+dfsg1-15) ...
Kaldırılıyor: libwinpr-library0.1:amd64 (1.1.0~git20140921.1.440916e+dfsg1-15) ...
Kaldırılıyor: libwinpr-rpc0.1:amd64 (1.1.0~git20140921.1.440916e+dfsg1-15) ...
Kaldırılıyor: libx264-148:amd64 (2:0.148.2795+gitaaa9aa8-1) ...
Kaldırılıyor: libxfont1:amd64 (1:1.5.2-4) ...
Kaldırılıyor: multiarch-support (2.27-3) ...
Kaldırılıyor: openjdk-8-jdk:amd64 (8u162-b12-1) ...
Kaldırılıyor: openjdk-8-jdk-headless:amd64 (8u162-b12-1) ...
Kaldırılıyor: openmpi-common (2.1.1-8) ...
Kaldırılıyor: php7.0-mysql (7.0.28-1) ...
Kaldırılıyor: python-functools32 (3.2.3.2-3) ...
Kaldırılıyor: python-httpretty (0.8.14-1) ...
Kaldırılıyor: python3-construct (2.8.16-0.2) ...
dpkg: uyarı: python3-construct kaldırılırken '/usr/lib/python3/dist-packages/construct/lib' dizini boş olmadığı için kaldırılmadı
dpkg: uyarı: python3-construct kaldırılırken '/usr/lib/python3/dist-packages/construct/examples/protocols' dizini boş olmadığı için kaldırılmadı
dpkg: uyarı: python3-construct kaldırılırken '/usr/lib/python3/dist-packages/construct/examples/formats/graphics' dizini boş olmadığı için kaldırılmadı
dpkg: uyarı: python3-construct kaldırılırken '/usr/lib/python3/dist-packages/construct/examples/formats/filesystem' dizini boş olmadığı için kaldırılmadı
dpkg: uyarı: python3-construct kaldırılırken '/usr/lib/python3/dist-packages/construct/examples/formats/executable' dizini boş olmadığı için kaldırılmadı
dpkg: uyarı: python3-construct kaldırılırken '/usr/lib/python3/dist-packages/construct/examples/formats/data' dizini boş olmadığı için kaldırılmadı
Kaldırılıyor: python3-cssutils (1.0.2-1) ...
dpkg: uyarı: python3-cssutils kaldırılırken '/usr/lib/python3.6/dist-packages/encutils' dizini boş olmadığı için kaldırılmadı
dpkg: uyarı: python3-cssutils kaldırılırken '/usr/lib/python3/dist-packages/encutils' dizini boş olmadığı için kaldırılmadı
dpkg: uyarı: python3-cssutils kaldırılırken '/usr/lib/python3/dist-packages/cssutils/tests/test_encutils' dizini boş olmadığı için kaldırılmadı
dpkg: uyarı: python3-cssutils kaldırılırken '/usr/lib/python3/dist-packages/cssutils/stylesheets' dizini boş olmadığı için kaldırılmadı
dpkg: uyarı: python3-cssutils kaldırılırken '/usr/lib/python3/dist-packages/cssutils/scripts' dizini boş olmadığı için kaldırılmadı
dpkg: uyarı: python3-cssutils kaldırılırken '/usr/lib/python3/dist-packages/cssutils/css' dizini boş olmadığı için kaldırılmadı
Kaldırılıyor: python3-feedparser (5.2.1-1) ...
dpkg: uyarı: python3-feedparser kaldırılırken '/usr/lib/python3/dist-packages/feedparser_debian' dizini boş olmadığı için kaldırılmadı
Kaldırılıyor: python3-html2text (2018.1.9-1) ...
Kaldırılıyor: readpst (0.6.59-1) ...
Kaldırılıyor: sbsigntool (0.6-3.2) ...
Kaldırılıyor: vino (3.22.0-3) ...
Kaldırılıyor: libopenmpi2:amd64 (2.1.1-8) ...
Kaldırılıyor: libfabric1 (1.5.3-1) ...
Kaldırılıyor: libopencv-videoio3.2:amd64 (3.2.0+dfsg-4+b4) ...
Kaldırılıyor: libpsm-infinipath1 (3.3+20.604758e7-5) ...
update-alternatives: uyarı: /usr/lib/libpsm1/libpsm_infinipath.so.1.16 alternatifi (libpsm_infinipath.so.1 bağ grubunun bir parçası) mevcut değil; alternatifler listesinden kaldırılıyor
update-alternatives: uyarı: /etc/alternatives/libpsm_infinipath.so.1 bağı kopmuş, en iyi seçenek ile güncellenecek
Kaldırılıyor: libqgis-core2.14.21 (2.14.21+dfsg-3) ...
Kaldırılıyor: libwinpr-utils0.1:amd64 (1.1.0~git20140921.1.440916e+dfsg1-15) ...
Kaldırılıyor: libwinpr-synch0.1:amd64 (1.1.0~git20140921.1.440916e+dfsg1-15) ...
Kaldırılıyor: libwinpr-thread0.1:amd64 (1.1.0~git20140921.1.440916e+dfsg1-15) ...
Kaldırılıyor: libwinpr-interlocked0.1:amd64 (1.1.0~git20140921.1.440916e+dfsg1-15) ...
Kaldırılıyor: libwinpr-handle0.1:amd64 (1.1.0~git20140921.1.440916e+dfsg1-15) ...
Kaldırılıyor: libwinpr-sysinfo0.1:amd64 (1.1.0~git20140921.1.440916e+dfsg1-15) ...
Kaldırılıyor: libopencv-imgcodecs3.2:amd64 (3.2.0+dfsg-4+b4) ...
Kaldırılıyor: libgdcm2.8:amd64 (2.8.4-1+b2) ...
Kaldırılıyor: libcharls1:amd64 (1.1.0+dfsg-2) ...
Kaldırılıyor: libopencv-imgproc3.2:amd64 (3.2.0+dfsg-4+b4) ...
Kaldırılıyor: libproj12:amd64 (4.9.3-2) ...
Kaldırılıyor: libsocket++1:amd64 (1.12.13-9) ...
Kaldırılıyor: libwinpr-crt0.1:amd64 (1.1.0~git20140921.1.440916e+dfsg1-15) ...
Kaldırılıyor: libopencv-core3.2:amd64 (3.2.0+dfsg-4+b4) ...
Kaldırılıyor: libtbb2:amd64 (2017~U7-8) ...
Ayarlanıyor: grub-efi-amd64 (2.02+dfsg1-4) ...
Installing for x86_64-efi platform.
Kurulum tamamlandı. Hata bildirilmedi.
Grub yapılandırma dosyası oluşturuluyor ...
Found background image: /usr/share/images/desktop-base/desktop-grub.png
Bulunan linux kalıbı: /boot/vmlinuz-4.15.0-kali2-amd64
Bulunan initrd kalıbı: /boot/initrd.img-4.15.0-kali2-amd64
Bulunan linux kalıbı: /boot/vmlinuz-4.14.0-kali3-amd64
Bulunan initrd kalıbı: /boot/initrd.img-4.14.0-kali3-amd64
dpkg: grub-efi-amd64 paketi işlenirken sorun yaşandı (--configure):
installed grub-efi-amd64 package post-installation script subprocess returned error exit status 1
Tetikleyiciler işleniyor: mime-support (3.60) ...
Tetikleyiciler işleniyor: desktop-file-utils (0.23-3) ...
Tetikleyiciler işleniyor: libapache2-mod-php7.0 (7.0.28-1) ...
Tetikleyiciler işleniyor: libglib2.0-0:amd64 (2.56.0-4) ...
Ayarlanıyor: linux-image-4.15.0-kali2-amd64 (4.15.11-1kali1) ...
/etc/kernel/postinst.d/initramfs-tools:
update-initramfs: Generating /boot/initrd.img-4.15.0-kali2-amd64
WARNING: Setting CRYPTSETUP in /etc/initramfs-tools/initramfs.conf is deprecated and will stop working in the future. Use /etc/cryptsetup-initramfs/conf-hook instead.
/etc/kernel/postinst.d/zz-update-grub:
Grub yapılandırma dosyası oluşturuluyor ...
Found background image: /usr/share/images/desktop-base/desktop-grub.png
Bulunan linux kalıbı: /boot/vmlinuz-4.15.0-kali2-amd64
Bulunan initrd kalıbı: /boot/initrd.img-4.15.0-kali2-amd64
Bulunan linux kalıbı: /boot/vmlinuz-4.14.0-kali3-amd64
Bulunan initrd kalıbı: /boot/initrd.img-4.14.0-kali3-amd64
run-parts: /etc/kernel/postinst.d/zz-update-grub exited with return code 1
dpkg: linux-image-4.15.0-kali2-amd64 paketi işlenirken sorun yaşandı (--configure):
installed linux-image-4.15.0-kali2-amd64 package post-installation script subprocess returned error exit status 1
dpkg: bağımlılık sorunları yüzünden linux-image-amd64 paketi yapılandırılamıyor:
linux-image-amd64 şuna bağımlı: linux-image-4.15.0-kali2-amd64, ama:
  linux-image-4.15.0-kali2-amd64 paketi henüz yapılandırılmadı.

dpkg: linux-image-amd64 paketi işlenirken sorun yaşandı (--configure):
bağımlılık sorunları - yapılandırılmadan bırakılıyor
Tetikleyiciler işleniyor: libc-bin (2.27-3) ...
Tetikleyiciler işleniyor: man-db (2.8.2-1) ...
Tetikleyiciler işleniyor: gnome-menus (3.13.3-11) ...
Tetikleyiciler işleniyor: hicolor-icon-theme (0.17-2) ...
İşleme sırasında hatalarla karşılaşıldı:
grub-efi-amd64
linux-image-4.15.0-kali2-amd64
linux-image-amd64
E: Sub-process /usr/bin/dpkg returned an error code (1)
Synaptic ile bozuk paketleri onarı seçin, ardından apt update çıktısını tekrar alalım. Muhtemelen bağlı çekirdek sürümünde grub ve boot ayarları karıştığından yapılandırma hataları veriyor. Ona ayrıca bakacağız.
 

Q_sySZero

Asistan
Katılım
7 Nisan 2018
Mesajlar
120
Reaksiyon puanı
7
Puanları
18
Yaş
21
Kod:
root@kali:~# sudo apt-get purge grub-efi-amd64
Paket listeleri okunuyor... Bitti
Bağımlılık ağacı oluşturuluyor       
Durum bilgisi okunuyor... Bitti     
Aşağıdaki paketler otomatik olarak kurulmuş ve artık bu paketlere gerek duyulmuyor:
  efibootmgr grub-efi-amd64-bin grub2-common libefiboot1 libefivar1
Bu paketleri kaldırmak için 'sudo apt autoremove' komutunu kullanın.
Aşağıdaki paketler KALDIRILACAK:
  grub-efi-amd64*
0 paket yükseltilecek, 0 yeni paket kurulacak, 1 paket kaldırılacak ve 0 paket yükseltilmeyecek.
3 paket tam olarak kurulmayacak ya da kaldırılmayacak.
Bu işlem tamamlandıktan sonra 218 kB disk alanı boşalacak.
Devam etmek istiyor musunuz? [E/h] e
(Veritabanı okunuyor ... 342645 dosya veya dizin kurulu durumda.)
Kaldırılıyor: grub-efi-amd64 (2.02+dfsg1-4) ...
Ayarlanıyor: linux-image-4.15.0-kali2-amd64 (4.15.11-1kali1) ...
/etc/kernel/postinst.d/initramfs-tools:
update-initramfs: Generating /boot/initrd.img-4.15.0-kali2-amd64
WARNING: Setting CRYPTSETUP in /etc/initramfs-tools/initramfs.conf is deprecated and will stop working in the future. Use /etc/cryptsetup-initramfs/conf-hook instead.
/etc/kernel/postinst.d/zz-update-grub:
Grub yapılandırma dosyası oluşturuluyor ...
Found background image: /usr/share/images/desktop-base/desktop-grub.png
Bulunan linux kalıbı: /boot/vmlinuz-4.15.0-kali2-amd64
Bulunan initrd kalıbı: /boot/initrd.img-4.15.0-kali2-amd64
Bulunan linux kalıbı: /boot/vmlinuz-4.14.0-kali3-amd64
Bulunan initrd kalıbı: /boot/initrd.img-4.14.0-kali3-amd64
run-parts: /etc/kernel/postinst.d/zz-update-grub exited with return code 1
dpkg: linux-image-4.15.0-kali2-amd64 paketi işlenirken sorun yaşandı (--configure):
 installed linux-image-4.15.0-kali2-amd64 package post-installation script subprocess returned error exit status 1
dpkg: bağımlılık sorunları yüzünden linux-image-amd64 paketi yapılandırılamıyor:
 linux-image-amd64 şuna bağımlı: linux-image-4.15.0-kali2-amd64, ama:
  linux-image-4.15.0-kali2-amd64 paketi henüz yapılandırılmadı.

dpkg: linux-image-amd64 paketi işlenirken sorun yaşandı (--configure):
 bağımlılık sorunları - yapılandırılmadan bırakılıyor
İşleme sırasında hatalarla karşılaşıldı:
 linux-image-4.15.0-kali2-amd64
 linux-image-amd64
E: Sub-process /usr/bin/dpkg returned an error code (1)
root@kali:~# sudo apt-get purge ^C
root@kali:~# sudo apt-get purge linux-image-4.15.0-kali2-amd64
Paket listeleri okunuyor... Bitti
Bağımlılık ağacı oluşturuluyor       
Durum bilgisi okunuyor... Bitti     
Aşağıdaki paketler otomatik olarak kurulmuş ve artık bu paketlere gerek duyulmuyor:
  efibootmgr grub-efi-amd64-bin grub2-common libefiboot1 libefivar1
Bu paketleri kaldırmak için 'sudo apt autoremove' komutunu kullanın.
Aşağıdaki paketler KALDIRILACAK:
  linux-image-4.15.0-kali2-amd64* linux-image-amd64*
0 paket yükseltilecek, 0 yeni paket kurulacak, 2 paket kaldırılacak ve 0 paket yükseltilmeyecek.
2 paket tam olarak kurulmayacak ya da kaldırılmayacak.
Bu işlem tamamlandıktan sonra 255 MB disk alanı boşalacak.
Devam etmek istiyor musunuz? [E/h] e
(Veritabanı okunuyor ... 342641 dosya veya dizin kurulu durumda.)
Kaldırılıyor: linux-image-amd64 (4.15+91+kali1) ...
Kaldırılıyor: linux-image-4.15.0-kali2-amd64 (4.15.11-1kali1) ...
I: /vmlinuz is now a symlink to boot/vmlinuz-4.14.0-kali3-amd64
I: /initrd.img is now a symlink to boot/initrd.img-4.14.0-kali3-amd64
/etc/kernel/postrm.d/initramfs-tools:
update-initramfs: Deleting /boot/initrd.img-4.15.0-kali2-amd64
/etc/kernel/postrm.d/zz-update-grub:
Grub yapılandırma dosyası oluşturuluyor ...
Found background image: /usr/share/images/desktop-base/desktop-grub.png
Bulunan linux kalıbı: /boot/vmlinuz-4.14.0-kali3-amd64
Bulunan initrd kalıbı: /boot/initrd.img-4.14.0-kali3-amd64
run-parts: /etc/kernel/postrm.d/zz-update-grub exited with return code 1
dpkg: linux-image-4.15.0-kali2-amd64 paketi işlenirken sorun yaşandı (--remove):
 installed linux-image-4.15.0-kali2-amd64 package post-removal script subprocess returned error exit status 1
İşleme sırasında hatalarla karşılaşıldı:
 linux-image-4.15.0-kali2-amd64
E: Sub-process /usr/bin/dpkg returned an error code (1)
root@kali:~# sudo apt-get purge linux-image-amd64
Paket listeleri okunuyor... Bitti
Bağımlılık ağacı oluşturuluyor       
Durum bilgisi okunuyor... Bitti     
'linux-image-amd64' kurulu değildi, dolayısıyla kaldırılmadı
Aşağıdaki paketler otomatik olarak kurulmuş ve artık bu paketlere gerek duyulmuyor:
  efibootmgr grub-efi-amd64-bin grub2-common libefiboot1 libefivar1
Bu paketleri kaldırmak için 'sudo apt autoremove' komutunu kullanın.
Aşağıdaki paketler KALDIRILACAK:
  linux-image-4.15.0-kali2-amd64
0 paket yükseltilecek, 0 yeni paket kurulacak, 1 paket kaldırılacak ve 0 paket yükseltilmeyecek.
1 paket tam olarak kurulmayacak ya da kaldırılmayacak.
Bu işlem tamamlandıktan sonra 255 MB disk alanı boşalacak.
Devam etmek istiyor musunuz? [E/h] e
(Veritabanı okunuyor ... 338392 dosya veya dizin kurulu durumda.)
Kaldırılıyor: linux-image-4.15.0-kali2-amd64 (4.15.11-1kali1) ...
/etc/kernel/postrm.d/initramfs-tools:
update-initramfs: Deleting /boot/initrd.img-4.15.0-kali2-amd64
/etc/kernel/postrm.d/zz-update-grub:
Grub yapılandırma dosyası oluşturuluyor ...
Found background image: /usr/share/images/desktop-base/desktop-grub.png
Bulunan linux kalıbı: /boot/vmlinuz-4.14.0-kali3-amd64
Bulunan initrd kalıbı: /boot/initrd.img-4.14.0-kali3-amd64
run-parts: /etc/kernel/postrm.d/zz-update-grub exited with return code 1
dpkg: linux-image-4.15.0-kali2-amd64 paketi işlenirken sorun yaşandı (--remove):
 installed linux-image-4.15.0-kali2-amd64 package post-removal script subprocess returned error exit status 1
İşleme sırasında hatalarla karşılaşıldı:
 linux-image-4.15.0-kali2-amd64
E: Sub-process /usr/bin/dpkg returned an error code (1)
root@kali:~# sudo apt-get purge linux-image-4.15.0-kali2-amd64
Paket listeleri okunuyor... Bitti
Bağımlılık ağacı oluşturuluyor       
Durum bilgisi okunuyor... Bitti     
Aşağıdaki paketler otomatik olarak kurulmuş ve artık bu paketlere gerek duyulmuyor:
  efibootmgr grub-efi-amd64-bin grub2-common libefiboot1 libefivar1
Bu paketleri kaldırmak için 'sudo apt autoremove' komutunu kullanın.
Aşağıdaki paketler KALDIRILACAK:
  linux-image-4.15.0-kali2-amd64
0 paket yükseltilecek, 0 yeni paket kurulacak, 1 paket kaldırılacak ve 0 paket yükseltilmeyecek.
1 paket tam olarak kurulmayacak ya da kaldırılmayacak.
Bu işlem tamamlandıktan sonra 255 MB disk alanı boşalacak.
Devam etmek istiyor musunuz? [E/h] e
(Veritabanı okunuyor ... 338392 dosya veya dizin kurulu durumda.)
Kaldırılıyor: linux-image-4.15.0-kali2-amd64 (4.15.11-1kali1) ...
/etc/kernel/postrm.d/initramfs-tools:
update-initramfs: Deleting /boot/initrd.img-4.15.0-kali2-amd64
/etc/kernel/postrm.d/zz-update-grub:
Grub yapılandırma dosyası oluşturuluyor ...
Found background image: /usr/share/images/desktop-base/desktop-grub.png
Bulunan linux kalıbı: /boot/vmlinuz-4.14.0-kali3-amd64
Bulunan initrd kalıbı: /boot/initrd.img-4.14.0-kali3-amd64
run-parts: /etc/kernel/postrm.d/zz-update-grub exited with return code 1
dpkg: linux-image-4.15.0-kali2-amd64 paketi işlenirken sorun yaşandı (--remove):
 installed linux-image-4.15.0-kali2-amd64 package post-removal script subprocess returned error exit status 1
İşleme sırasında hatalarla karşılaşıldı:
 linux-image-4.15.0-kali2-amd64
E: Sub-process /usr/bin/dpkg returned an error code (1)
root@kali:~# sudo apt-get grub-efi-amd64
E: Geçersiz işlem: grub-efi-amd64
root@kali:~#

Şimdı bu komutları uyguladım :D

---- Mesajlar birleştirildi ----

Kod:
root@kali:~# apt-get install synaptic
Paket listeleri okunuyor... Bitti
Bağımlılık ağacı oluşturuluyor       
Durum bilgisi okunuyor... Bitti     
Aşağıdaki paketler otomatik olarak kurulmuş ve artık bu paketlere gerek duyulmuyor:
  efibootmgr grub-efi-amd64-bin grub2-common libefiboot1 libefivar1
Bu paketleri kaldırmak için 'apt autoremove' komutunu kullanın.
Aşağıdaki ek paketler kurulacak:
  docbook-xml libept1.5.0 librarian0 rarian-compat sgml-data
Önerilen paketler:
  docbook docbook-dsssl docbook-xsl docbook-defguide perlsgml w3-recs opensp
  dwww deborphan apt-xapian-index
Aşağıdaki paketler KALDIRILACAK:
  linux-image-4.15.0-kali2-amd64
Aşağıdaki YENİ paketler kurulacak:
  docbook-xml libept1.5.0 librarian0 rarian-compat sgml-data synaptic
0 paket yükseltilecek, 6 yeni paket kurulacak, 1 paket kaldırılacak ve 0 paket yükseltilmeyecek.
1 paket tam olarak kurulmayacak ya da kaldırılmayacak.
0 B/2.577 kB arşiv dosyası indirilecek.
Bu işlem tamamlandıktan sonra 242 MB disk alanı boşalacak.
Devam etmek istiyor musunuz? [E/h] e
(Veritabanı okunuyor ... 338392 dosya veya dizin kurulu durumda.)
Kaldırılıyor: linux-image-4.15.0-kali2-amd64 (4.15.11-1kali1) ...
/etc/kernel/postrm.d/initramfs-tools:
update-initramfs: Deleting /boot/initrd.img-4.15.0-kali2-amd64
/etc/kernel/postrm.d/zz-update-grub:
Grub yapılandırma dosyası oluşturuluyor ...
Found background image: /usr/share/images/desktop-base/desktop-grub.png
Bulunan linux kalıbı: /boot/vmlinuz-4.14.0-kali3-amd64
Bulunan initrd kalıbı: /boot/initrd.img-4.14.0-kali3-amd64
run-parts: /etc/kernel/postrm.d/zz-update-grub exited with return code 1
dpkg: linux-image-4.15.0-kali2-amd64 paketi işlenirken sorun yaşandı (--remove):
 installed linux-image-4.15.0-kali2-amd64 package post-removal script subprocess returned error exit status 1
İşleme sırasında hatalarla karşılaşıldı:
 linux-image-4.15.0-kali2-amd64
E: Sub-process /usr/bin/dpkg returned an error code (1)

---- Mesajlar birleştirildi ----

yüklenenler listesinde gözükmüyor bu hatayı veriyo
 
Son düzenleme:

Hopeツ︎

Profesör
Emektar
Katılım
9 Mart 2016
Mesajlar
1,851
Çözümler
1
Reaksiyon puanı
1,892
Puanları
113
Yaş
24
Kod:
root@kali:~# sudo apt-get purge grub-efi-amd64
Paket listeleri okunuyor... Bitti
Bağımlılık ağacı oluşturuluyor     
Durum bilgisi okunuyor... Bitti   
Aşağıdaki paketler otomatik olarak kurulmuş ve artık bu paketlere gerek duyulmuyor:
  efibootmgr grub-efi-amd64-bin grub2-common libefiboot1 libefivar1
Bu paketleri kaldırmak için 'sudo apt autoremove' komutunu kullanın.
Aşağıdaki paketler KALDIRILACAK:
  grub-efi-amd64*
0 paket yükseltilecek, 0 yeni paket kurulacak, 1 paket kaldırılacak ve 0 paket yükseltilmeyecek.
3 paket tam olarak kurulmayacak ya da kaldırılmayacak.
Bu işlem tamamlandıktan sonra 218 kB disk alanı boşalacak.
Devam etmek istiyor musunuz? [E/h] e
(Veritabanı okunuyor ... 342645 dosya veya dizin kurulu durumda.)
Kaldırılıyor: grub-efi-amd64 (2.02+dfsg1-4) ...
Ayarlanıyor: linux-image-4.15.0-kali2-amd64 (4.15.11-1kali1) ...
/etc/kernel/postinst.d/initramfs-tools:
update-initramfs: Generating /boot/initrd.img-4.15.0-kali2-amd64
WARNING: Setting CRYPTSETUP in /etc/initramfs-tools/initramfs.conf is deprecated and will stop working in the future. Use /etc/cryptsetup-initramfs/conf-hook instead.
/etc/kernel/postinst.d/zz-update-grub:
Grub yapılandırma dosyası oluşturuluyor ...
Found background image: /usr/share/images/desktop-base/desktop-grub.png
Bulunan linux kalıbı: /boot/vmlinuz-4.15.0-kali2-amd64
Bulunan initrd kalıbı: /boot/initrd.img-4.15.0-kali2-amd64
Bulunan linux kalıbı: /boot/vmlinuz-4.14.0-kali3-amd64
Bulunan initrd kalıbı: /boot/initrd.img-4.14.0-kali3-amd64
run-parts: /etc/kernel/postinst.d/zz-update-grub exited with return code 1
dpkg: linux-image-4.15.0-kali2-amd64 paketi işlenirken sorun yaşandı (--configure):
installed linux-image-4.15.0-kali2-amd64 package post-installation script subprocess returned error exit status 1
dpkg: bağımlılık sorunları yüzünden linux-image-amd64 paketi yapılandırılamıyor:
linux-image-amd64 şuna bağımlı: linux-image-4.15.0-kali2-amd64, ama:
  linux-image-4.15.0-kali2-amd64 paketi henüz yapılandırılmadı.

dpkg: linux-image-amd64 paketi işlenirken sorun yaşandı (--configure):
bağımlılık sorunları - yapılandırılmadan bırakılıyor
İşleme sırasında hatalarla karşılaşıldı:
linux-image-4.15.0-kali2-amd64
linux-image-amd64
E: Sub-process /usr/bin/dpkg returned an error code (1)
root@kali:~# sudo apt-get purge ^C
root@kali:~# sudo apt-get purge linux-image-4.15.0-kali2-amd64
Paket listeleri okunuyor... Bitti
Bağımlılık ağacı oluşturuluyor     
Durum bilgisi okunuyor... Bitti   
Aşağıdaki paketler otomatik olarak kurulmuş ve artık bu paketlere gerek duyulmuyor:
  efibootmgr grub-efi-amd64-bin grub2-common libefiboot1 libefivar1
Bu paketleri kaldırmak için 'sudo apt autoremove' komutunu kullanın.
Aşağıdaki paketler KALDIRILACAK:
  linux-image-4.15.0-kali2-amd64* linux-image-amd64*
0 paket yükseltilecek, 0 yeni paket kurulacak, 2 paket kaldırılacak ve 0 paket yükseltilmeyecek.
2 paket tam olarak kurulmayacak ya da kaldırılmayacak.
Bu işlem tamamlandıktan sonra 255 MB disk alanı boşalacak.
Devam etmek istiyor musunuz? [E/h] e
(Veritabanı okunuyor ... 342641 dosya veya dizin kurulu durumda.)
Kaldırılıyor: linux-image-amd64 (4.15+91+kali1) ...
Kaldırılıyor: linux-image-4.15.0-kali2-amd64 (4.15.11-1kali1) ...
I: /vmlinuz is now a symlink to boot/vmlinuz-4.14.0-kali3-amd64
I: /initrd.img is now a symlink to boot/initrd.img-4.14.0-kali3-amd64
/etc/kernel/postrm.d/initramfs-tools:
update-initramfs: Deleting /boot/initrd.img-4.15.0-kali2-amd64
/etc/kernel/postrm.d/zz-update-grub:
Grub yapılandırma dosyası oluşturuluyor ...
Found background image: /usr/share/images/desktop-base/desktop-grub.png
Bulunan linux kalıbı: /boot/vmlinuz-4.14.0-kali3-amd64
Bulunan initrd kalıbı: /boot/initrd.img-4.14.0-kali3-amd64
run-parts: /etc/kernel/postrm.d/zz-update-grub exited with return code 1
dpkg: linux-image-4.15.0-kali2-amd64 paketi işlenirken sorun yaşandı (--remove):
installed linux-image-4.15.0-kali2-amd64 package post-removal script subprocess returned error exit status 1
İşleme sırasında hatalarla karşılaşıldı:
linux-image-4.15.0-kali2-amd64
E: Sub-process /usr/bin/dpkg returned an error code (1)
root@kali:~# sudo apt-get purge linux-image-amd64
Paket listeleri okunuyor... Bitti
Bağımlılık ağacı oluşturuluyor     
Durum bilgisi okunuyor... Bitti   
'linux-image-amd64' kurulu değildi, dolayısıyla kaldırılmadı
Aşağıdaki paketler otomatik olarak kurulmuş ve artık bu paketlere gerek duyulmuyor:
  efibootmgr grub-efi-amd64-bin grub2-common libefiboot1 libefivar1
Bu paketleri kaldırmak için 'sudo apt autoremove' komutunu kullanın.
Aşağıdaki paketler KALDIRILACAK:
  linux-image-4.15.0-kali2-amd64
0 paket yükseltilecek, 0 yeni paket kurulacak, 1 paket kaldırılacak ve 0 paket yükseltilmeyecek.
1 paket tam olarak kurulmayacak ya da kaldırılmayacak.
Bu işlem tamamlandıktan sonra 255 MB disk alanı boşalacak.
Devam etmek istiyor musunuz? [E/h] e
(Veritabanı okunuyor ... 338392 dosya veya dizin kurulu durumda.)
Kaldırılıyor: linux-image-4.15.0-kali2-amd64 (4.15.11-1kali1) ...
/etc/kernel/postrm.d/initramfs-tools:
update-initramfs: Deleting /boot/initrd.img-4.15.0-kali2-amd64
/etc/kernel/postrm.d/zz-update-grub:
Grub yapılandırma dosyası oluşturuluyor ...
Found background image: /usr/share/images/desktop-base/desktop-grub.png
Bulunan linux kalıbı: /boot/vmlinuz-4.14.0-kali3-amd64
Bulunan initrd kalıbı: /boot/initrd.img-4.14.0-kali3-amd64
run-parts: /etc/kernel/postrm.d/zz-update-grub exited with return code 1
dpkg: linux-image-4.15.0-kali2-amd64 paketi işlenirken sorun yaşandı (--remove):
installed linux-image-4.15.0-kali2-amd64 package post-removal script subprocess returned error exit status 1
İşleme sırasında hatalarla karşılaşıldı:
linux-image-4.15.0-kali2-amd64
E: Sub-process /usr/bin/dpkg returned an error code (1)
root@kali:~# sudo apt-get purge linux-image-4.15.0-kali2-amd64
Paket listeleri okunuyor... Bitti
Bağımlılık ağacı oluşturuluyor     
Durum bilgisi okunuyor... Bitti   
Aşağıdaki paketler otomatik olarak kurulmuş ve artık bu paketlere gerek duyulmuyor:
  efibootmgr grub-efi-amd64-bin grub2-common libefiboot1 libefivar1
Bu paketleri kaldırmak için 'sudo apt autoremove' komutunu kullanın.
Aşağıdaki paketler KALDIRILACAK:
  linux-image-4.15.0-kali2-amd64
0 paket yükseltilecek, 0 yeni paket kurulacak, 1 paket kaldırılacak ve 0 paket yükseltilmeyecek.
1 paket tam olarak kurulmayacak ya da kaldırılmayacak.
Bu işlem tamamlandıktan sonra 255 MB disk alanı boşalacak.
Devam etmek istiyor musunuz? [E/h] e
(Veritabanı okunuyor ... 338392 dosya veya dizin kurulu durumda.)
Kaldırılıyor: linux-image-4.15.0-kali2-amd64 (4.15.11-1kali1) ...
/etc/kernel/postrm.d/initramfs-tools:
update-initramfs: Deleting /boot/initrd.img-4.15.0-kali2-amd64
/etc/kernel/postrm.d/zz-update-grub:
Grub yapılandırma dosyası oluşturuluyor ...
Found background image: /usr/share/images/desktop-base/desktop-grub.png
Bulunan linux kalıbı: /boot/vmlinuz-4.14.0-kali3-amd64
Bulunan initrd kalıbı: /boot/initrd.img-4.14.0-kali3-amd64
run-parts: /etc/kernel/postrm.d/zz-update-grub exited with return code 1
dpkg: linux-image-4.15.0-kali2-amd64 paketi işlenirken sorun yaşandı (--remove):
installed linux-image-4.15.0-kali2-amd64 package post-removal script subprocess returned error exit status 1
İşleme sırasında hatalarla karşılaşıldı:
linux-image-4.15.0-kali2-amd64
E: Sub-process /usr/bin/dpkg returned an error code (1)
root@kali:~# sudo apt-get grub-efi-amd64
E: Geçersiz işlem: grub-efi-amd64
root@kali:~#

Şimdı bu komutları uyguladım :D

---- Mesajlar birleştirildi ----

Kod:
root@kali:~# apt-get install synaptic
Paket listeleri okunuyor... Bitti
Bağımlılık ağacı oluşturuluyor     
Durum bilgisi okunuyor... Bitti   
Aşağıdaki paketler otomatik olarak kurulmuş ve artık bu paketlere gerek duyulmuyor:
  efibootmgr grub-efi-amd64-bin grub2-common libefiboot1 libefivar1
Bu paketleri kaldırmak için 'apt autoremove' komutunu kullanın.
Aşağıdaki ek paketler kurulacak:
  docbook-xml libept1.5.0 librarian0 rarian-compat sgml-data
Önerilen paketler:
  docbook docbook-dsssl docbook-xsl docbook-defguide perlsgml w3-recs opensp
  dwww deborphan apt-xapian-index
Aşağıdaki paketler KALDIRILACAK:
  linux-image-4.15.0-kali2-amd64
Aşağıdaki YENİ paketler kurulacak:
  docbook-xml libept1.5.0 librarian0 rarian-compat sgml-data synaptic
0 paket yükseltilecek, 6 yeni paket kurulacak, 1 paket kaldırılacak ve 0 paket yükseltilmeyecek.
1 paket tam olarak kurulmayacak ya da kaldırılmayacak.
0 B/2.577 kB arşiv dosyası indirilecek.
Bu işlem tamamlandıktan sonra 242 MB disk alanı boşalacak.
Devam etmek istiyor musunuz? [E/h] e
(Veritabanı okunuyor ... 338392 dosya veya dizin kurulu durumda.)
Kaldırılıyor: linux-image-4.15.0-kali2-amd64 (4.15.11-1kali1) ...
/etc/kernel/postrm.d/initramfs-tools:
update-initramfs: Deleting /boot/initrd.img-4.15.0-kali2-amd64
/etc/kernel/postrm.d/zz-update-grub:
Grub yapılandırma dosyası oluşturuluyor ...
Found background image: /usr/share/images/desktop-base/desktop-grub.png
Bulunan linux kalıbı: /boot/vmlinuz-4.14.0-kali3-amd64
Bulunan initrd kalıbı: /boot/initrd.img-4.14.0-kali3-amd64
run-parts: /etc/kernel/postrm.d/zz-update-grub exited with return code 1
dpkg: linux-image-4.15.0-kali2-amd64 paketi işlenirken sorun yaşandı (--remove):
installed linux-image-4.15.0-kali2-amd64 package post-removal script subprocess returned error exit status 1
İşleme sırasında hatalarla karşılaşıldı:
linux-image-4.15.0-kali2-amd64
E: Sub-process /usr/bin/dpkg returned an error code (1)

yüklenenler listesinde gözükmüyor bu hatayı veriyo
Neden böyle bir şey yaptın? grub ve kernelin image dosyalarını silmeye çalıştığının farkındasındır umarım. Sistemi yeniden başlattığında erişebileceğine dair şüpheliyim. Sistemi yeniden başlat ve başarılı olursan üstteki seçenek değilde (güncel olmayan çekirdek sürümü) altlarda daha önce sürüm varsa ondan açmaya çalış sistemi. Şimdilik böyle açabilirsen (umarım) güncel çekirdeği ya adam etmeyi deneriz ya da onarırız.
 
Son düzenleme:

Q_sySZero

Asistan
Katılım
7 Nisan 2018
Mesajlar
120
Reaksiyon puanı
7
Puanları
18
Yaş
21
Neden böyle bir şey yaptın? grub ve kernelin image dosyalarını silmeye çalıştığının farkındasındır umarım. Sistemi yeniden başlattığında erişebileceğine dair şüpheliyim. Sistemi yeniden başlat ve başarılı olursan üstteki seçenek değilde (güncel olmayan çekirdek sürümü) altlarda daha önce sürüm varsa ondan açmaya çalış sistemi. Şimdilik böyle açabilirsen (umarım) güncel çekirdeği ya adam etmeyi deneriz ya da onarırız.
hocam 3 gündür aynı şeyle uğraşınva iyice sinirim bozuldu şuan aynen bir yerde silip kurmakla ilgili bir yazı yazıyodu artık sabrım kalmadığı için yazıp uygulamayı denedim açıldı sistem sıkıntı yok şuan :)

---- Mesajlar birleştirildi ----

sürekli fail alıp alıp duruyorum artık HDD söküp parçalayacam
 
Son düzenleme:

Hopeツ︎

Profesör
Emektar
Katılım
9 Mart 2016
Mesajlar
1,851
Çözümler
1
Reaksiyon puanı
1,892
Puanları
113
Yaş
24
hocam 3 gündür aynı şeyle uğraşınva iyice sinirim bozuldu şuan aynen bir yerde silip kurmakla ilgili bir yazı yazıyodu artık sabrım kalmadığı için yazıp uygulamayı denedim açıldı sistem sıkıntı yok şuan :)

---- Mesajlar birleştirildi ----

sürekli fail alıp alıp duruyorum artık HDD söküp parçalayacam
Dostum grub ve boot ayarları o kadar kurcalanmışki bunları zaten çıktılardan anlamak güç değil. Sana söylediğimde ince mince demiştin olsun, olsun ama bak böyle sıkıntılar oluşuyor... Terminale girdiğin her komuta dikkat etmelisin buna apt update, apt upgrade, dist-upgrade dahil. En son yaptığın silme işlemlerinin gerçekleşmemesini de dpkg sisteminin çöküşüne bağlıyorum ayrıca kernel imagelerinin işlenmemesi de aynı şekilde.
 

Q_sySZero

Asistan
Katılım
7 Nisan 2018
Mesajlar
120
Reaksiyon puanı
7
Puanları
18
Yaş
21
Dostum grub ve boot ayarları o kadar kurcalanmışki bunları zaten çıktılardan anlamak güç değil. Sana söylediğimde ince mince demiştin olsun, olsun ama bak böyle sıkıntılar oluşuyor... Terminale girdiğin her komuta dikkat etmelisin buna apt update, apt upgrade, dist-upgrade dahil. En son yaptığın silme işlemlerinin gerçekleşmemesini de dpkg sisteminin çöküşüne bağlıyorum ayrıca kernel imagelerinin işlenmemesi de aynı şekilde.
İnce mince dedim ama ciddiyetin farkındayım onu şu anlamda dedim eğer bi sıkıntı olursa sistemi silerim sistemde harhangi bir önemli kaydım yok 2 3 yıl kullanıp da özel dosyalarımın biriktiği sisteme tabikide bu kadar acımasız olmam :D + 3 gündür sürekli bişeyler deneyip durduk bozula bilir basit bir işlem varsa başlayalım yoksa ben sistemi komple silicem onun anlatımını yapın :)

---- Mesajlar birleştirildi ----

hocam direl çözüme geçelim şimdi ne yapmam lazım vaktim daralıyo çünkü

---- Mesajlar birleştirildi ----

sistem dual boot :D efi den kaydı silselmde genede boot menu de gözüküyo tam bir silme işlemini nasıl yaparız eğer çözüm olmayacaksa her mesajınız 15 dk da bir geliyor size bişey demiyorum ama hiç ilerleme olmaması aşırı derece sinir bozucu bişey
 
Son düzenleme:

Hopeツ︎

Profesör
Emektar
Katılım
9 Mart 2016
Mesajlar
1,851
Çözümler
1
Reaksiyon puanı
1,892
Puanları
113
Yaş
24
İnce mince dedim ama ciddiyetin farkındayım onu şu anlamda dedim eğer bi sıkıntı olursa sistemi silerim sistemde harhangi bir önemli kaydım yok 2 3 yıl kullanıp da özel dosyalarımın biriktiği sisteme tabikide bu kadar acımasız olmam :D + 3 gündür sürekli bişeyler deneyip durduk bozula bilir basit bir işlem varsa başlayalım yoksa ben sistemi komple silicem onun anlatımını yapın :)

---- Mesajlar birleştirildi ----

hocam direl çözüme geçelim şimdi ne yapmam lazım vaktim daralıyo çünkü

---- Mesajlar birleştirildi ----

sistem dual boot :D efi den kaydı silselmde genede boot menu de gözüküyo tam bir silme işlemini nasıl yaparız eğer çözüm olmayacaksa her mesajınız 15 dk da bir geliyor size bişey demiyorum ama hiç ilerleme olmaması aşırı derece sinir bozucu bişey
Yemeğe geçmem gerekiyordu üzgünüm... Sistem açılır açılmasına fakat yüklemelerde sürekli bir sıkıntı yaşanır. Kerneli onarmaya, silmeye, değiştirmeye çalışana kadar temiz bir sistem kurulumu yaparsın şu durumda daha mantıklı. İlerleme yaşayamıyoruz diyorsun fakat bir sürü yeni komut öğrendin. Konuda o kadar fazla komut var ki beynim yandı... Ben bile Linux konularımda bu kadar komut anlatımı yapmıyorum :rolleyes:
Velhasılkelam özetleyecek olursam, bir çok konuyu aştın sistemini yeniden kur mademki sıkıntı arz edecek bir yedekleme durumun yok. Kur fakat rica ediyorum grub ve boot ayarlarını bu kadar kurcalama yine aynı sıkıntıları yaşayacaksın yaparsan çünkü. Birde şunu bilmeni isterim, bende sistemin kurcalanıp deneme yanılma yöntemleriyle öğrenilmesinden yanayım. Lakin gereksiz hamlelerin dışında...
 

Q_sySZero

Asistan
Katılım
7 Nisan 2018
Mesajlar
120
Reaksiyon puanı
7
Puanları
18
Yaş
21
Yemeğe geçmem gerekiyordu üzgünüm... Sistem açılır açılmasına fakat yüklemelerde sürekli bir sıkıntı yaşanır. Kerneli onarmaya, silmeye, değiştirmeye çalışana kadar temiz bir sistem kurulumu yaparsın şu durumda daha mantıklı. İlerleme yaşayamıyoruz diyorsun fakat bir sürü yeni komut öğrendin. Konuda o kadar fazla komut var ki beynim yandı... Ben bile Linux konularımda bu kadar komut anlatımı yapmıyorum :rolleyes:
Velhasılkelam özetleyecek olursam, bir çok konuyu aştın sistemini yeniden kur mademki sıkıntı arz edecek bir yedekleme durumun yok. Kur fakat rica ediyorum grub ve boot ayarlarını bu kadar kurcalama yine aynı sıkıntıları yaşayacaksın yaparsan çünkü. Birde şunu bilmeni isterim, bende sistemin kurcalanıp deneme yanılma yöntemleriyle öğrenilmesinden yanayım. Lakin gereksiz hamlelerin dışında...
altını çizeyim sinirden :D hiç bişey bilmeyen birisi oradaki linux yazısını görünce burada linux yazıyo demekki bu açılış sistemi etkiliyo buna dokunmayam der :D ben delilik yaptım silinirse silinsin dedim neyse :) saat olmuş 9 şimdi sistemi kurup tekrar silmek bana cazip gelmiyo eğer 3 saati aşmaz diyorsanız ben manuel kurcalayarak daha fazla bilgi almak istediğim için bu şekilde ayarlar yapmaya devam edelim ama yok uzun sürebilir windows a falan da zarar verme riski yüksek diyorsanız o zaman dual boot kali linuxu nasıl tamamen kökünden güvenli bir şekilde kaldırabiliriz ona odaklananım ama dediğim gibi manuel devam etme taraftarıyım ne kadar sinir olsamda bir çok şey öğrendim (3 saati aşmayacaksa)
 

Hopeツ︎

Profesör
Emektar
Katılım
9 Mart 2016
Mesajlar
1,851
Çözümler
1
Reaksiyon puanı
1,892
Puanları
113
Yaş
24
altını çizeyim sinirden :D hiç bişey bilmeyen birisi oradaki linux yazısını görünce burada linux yazıyo demekki bu açılış sistemi etkiliyo buna dokunmayam der :D ben delilik yaptım silinirse silinsin dedim neyse :) saat olmuş 9 şimdi sistemi kurup tekrar silmek bana cazip gelmiyo eğer 3 saati aşmaz diyorsanız ben manuel kurcalayarak daha fazla bilgi almak istediğim için bu şekilde ayarlar yapmaya devam edelim ama yok uzun sürebilir windows a falan da zarar verme riski yüksek diyorsanız o zaman dual boot kali linuxu nasıl tamamen kökünden güvenli bir şekilde kaldırabiliriz ona odaklananım ama dediğim gibi manuel devam etme taraftarıyım ne kadar sinir olsamda bir çok şey öğrendim (3 saati aşmayacaksa)
Sorun değil, kernel işinin riski yüksek grub ekranına erişememeye kadar yolu var acemilik zamanlarımda başıma geldi biliyorum... Öğrenmek istediğinin farkındayım fakat düzeltmeye çalışırken daha çok bozman olası. Şimdilik için bunu esgeç, Yeniden kurulum için ekstra bir şey yapmana gerek yok CD/DVD, USB hangi aygıta yazdıysan kurulum dosyalarını tak kurulum ekranında önceki sistemin olduğu bölümleri sil ve tekrar yükle hepsi bu.
 

Q_sySZero

Asistan
Katılım
7 Nisan 2018
Mesajlar
120
Reaksiyon puanı
7
Puanları
18
Yaş
21
Sorun değil, kernel işinin riski yüksek grub ekranına erişememeye kadar yolu var acemilik zamanlarımda başıma geldi biliyorum... Öğrenmek istediğinin farkındayım fakat düzeltmeye çalışırken daha çok bozman olası. Şimdilik için bunu esgeç, Yeniden kurulum için ekstra bir şey yapmana gerek yok CD/DVD, USB hangi aygıta yazdıysan kurulum dosyalarını tak kurulum ekranında önceki sistemin olduğu bölümleri sil ve tekrar yükle hepsi bu.
şöyle bir sıkıntı bir komutu çalıştırdıktan sonra kali_grub diye boot menude yeni bir ayar belirdi aynı şekilde kalinin bölümlerini sildikten sonrada boot menu de kali gözükmeye devam ediyor bunları nasıl silebiliriz :) kökten sileceğim çünkü çok kurcaladım oraları :)

---- Mesajlar birleştirildi ----

ayrıca grub ekranın arişemem olayı baıma geldi :D boot menu den windowsu başlatıyorum ki hala oradan başlatıyorum sorunda zaten windows un GRUB da olmaması :D :D

---- Mesajlar birleştirildi ----

eğer manuel yaparsak GRUB ekranı çöksün ona sıkıntı olmaz :) bios aayrları ve windows u boot menuden başlatırken sıkıntı çıkarmaaycaksa onun dışındaki sıkıntılar önemli değil ve dediğim gibi ben kaliyi kökten silmek sitiyorum bunu nasıl yapacğımı bilmek istiyorum ilerde komple kurtulmak sitersem boot menu de veefi de falan kalıntıları olmasın ve gene dediğim gibi GRUB önemli değil efi den silince gurub yok oluyo ve windows boot mananger de bi sıkıntı olmuyo :) oraya bağlı değil sanırım :)
 
Son düzenleme:

Hopeツ︎

Profesör
Emektar
Katılım
9 Mart 2016
Mesajlar
1,851
Çözümler
1
Reaksiyon puanı
1,892
Puanları
113
Yaş
24
şöyle bir sıkıntı bir komutu çalıştırdıktan sonra kali_grub diye boot menude yeni bir ayar belirdi aynı şekilde kalinin bölümlerini sildikten sonrada boot menu de kali gözükmeye devam ediyor bunları nasıl silebiliriz :) kökten sileceğim çünkü çok kurcaladım oraları :)

---- Mesajlar birleştirildi ----

ayrıca grub ekranın arişemem olayı baıma geldi :D boot menu den windowsu başlatıyorum ki hala oradan başlatıyorum sorunda zaten windows un GRUB da olmaması :D:D
Dostum, anlatmak istediğim şu... Kali Linux'u ne yardımı ile kurduysan tak boot ettir kurulum ekranına ulaş sonra sil o linux bölümlerinin hepsini. Kalinin bölümlerini canlı medyada sildikten sonra grub ekranında herhangi bir seçenek görmen mümkün değil zaten, göreceksende yeni kurduğun alanı görürsün. Windows'a boot ekranından ulaş grubdan ulaşma bunu daha öncede söyledim. Tamam bende onu söylüyorum işte dediğimi yap hatalı sistemini sil temiz sistemini kur. Anlatamadığım ya da anlamadığım bir şey mi var eğer varsa söyle.
 

Q_sySZero

Asistan
Katılım
7 Nisan 2018
Mesajlar
120
Reaksiyon puanı
7
Puanları
18
Yaş
21
Tam anlatamadım :D şöyle dediğinizi yaptığımda yeni kaliyi kurmuş ve sağlıklı bir şekilde devam etmiş olacağım lakin ilerde eğer kaliyi komple yok etmek istersem sadece bölümleri silmek yeterli olmuyor bilgisayarımda kali ile ilgili hiç bir şey kalmamasını istiyorum :D bölümleri sildiğimde gene kalinin GRUB önyükleyici penceresi karşıma çıkıyor ha işte ben onu komple yok etmek istiyorum ilerde eğer kaliyi komple silmek istediğimde bunu nasıl yapacağım

USB yi takıp KAli yükleme sistemi ile bölümleri sil dediğimde aynı şekilde GRUB önyükleme ekranıda silinecekmi çünkü ben windows ta bölümleri silip yeniden başlattığımda kalinin grub ekranı çıkıyordu ayrıca bide boot menude gözüküyordu gene böle olacaksa olamamsı için bir çözüm öneriniz varmı :)
 

Hopeツ︎

Profesör
Emektar
Katılım
9 Mart 2016
Mesajlar
1,851
Çözümler
1
Reaksiyon puanı
1,892
Puanları
113
Yaş
24
Tam anlatamadım :D şöyle dediğinizi yaptığımda yeni kaliyi kurmuş ve sağlıklı bir şekilde devam etmiş olacağım lakin ilerde eğer kaliyi komple yok etmek istersem sadece bölümleri silmek yeterli olmuyor bilgisayarımda kali ile ilgili hiç bir şey kalmamasını istiyorum :D bölümleri sildiğimde gene kalinin GRUB önyükleyici penceresi karşıma çıkıyor ha işte ben onu komple yok etmek istiyorum ilerde eğer kaliyi komple silmek istediğimde bunu nasıl yapacağım

USB yi takıp KAli yükleme sistemi ile bölümleri sil dediğimde aynı şekilde GRUB önyükleme ekranıda silinecekmi çünkü ben windows ta bölümleri silip yeniden başlattığımda kalinin grub ekranı çıkıyordu ayrıca bide boot menude gözüküyordu gene böle olacaksa olamamsı için bir çözüm öneriniz varmı :)
''Usb'yi takıp kali yükleme sistemi ile bölümleri sil dediğinde'' grub ekranıda yok olacak. Yani mantıken düşünelim, sen kurulu bölüm öbeklerini hdd ya da ssd den siliyorsun bir daha grub ekranını görme veya sisteme ulaşma gibi bir şansın istesende olmaz. Ayrıca boot menüde falanda gözükmez bak o kadar dağıtım silip kurdum şu ana kadar böyle bir şeyle henüz karşılaşmadım karşılaşanıda görmedim. Sen bu işlemi gerçekleştirdikten sonra ister başka dağıtıma geç ister tekrar aynı dağıtımın kurulumunu yap, yeni kurulum dosyalarıyla yeniden şekillenir sistemin. Bu dediğin nasıl olur biliyor musun? Linux kurarken bir kaç bölüm oluşturuyor ya sistem hani bir köşesini silip bir köşesini bırakırsın bak o zaman ya boot menude çıkar ya da grubda bir şeyler görürsün eski kuruluma ait. Konu şu, sen böyle bir şey yapmayacaksın komple yok edeceksin. Çözüm önerim budur gerçekten ilk bunları aşmaya çalış kernel işine şimdi girişmeye kalksaydık... İyi ki kalkmamışız yanlış anlama beni lütfen. Sistemi çökertip yeniden kurup, xorg'u tekrar yapılandırıp, kerneli yükseltip, kerneli düzenlemeye çalışıp olayı kendince kavramış biri olarak yazıyorum bunları. Öğüt vermek gibi olmasında bir en üst basamağa birden atlanmaz ilk önce küçük basamaklar çıkılır her zaman.
 

Q_sySZero

Asistan
Katılım
7 Nisan 2018
Mesajlar
120
Reaksiyon puanı
7
Puanları
18
Yaş
21
bi deneyim size açıklarım dediğiniz anladım çünkü windowsta bölümleri silip yeniden başlattığımda grub ekranı hata veriyodu recue grub diye sonra araştırdım efi deki kaliyi silmek gerekiyodu onu da sildim sonra boot menu de kali gözüküyodu sadece :) ben dediğinizi yapıcam :)

---- Mesajlar birleştirildi ----

Hocammmm ben anlatamıyorum bakın kuruluma zorluyo USB den başlatınca
Size açıkca anlaatcam şimdi şuanda ben evet kaliyi tekrar kuracam tamam bunu biliyoruz bunda sıkıntı yok
sizden istediğim kaliyi tekrar kurmak değil bakın anlatıyorum
şimdi USB yi taktım ve kali linux instaler a geldim oradan bölümleri sil dedim ama devam etmeye zorluyo yani kaliyi yükletiyo
Şimdi ilerde ben Kali linux u komple kaldırmak isteeyceğim değil mi işte onu nasıl yapacam bilgisayarımda kali linux olmayacak bakın mesele bu siz USB den yap diyorsunuz ancak USB den kaliyi başlattığımda benim tekrar kurmama zorluyo bölümleri sildiğimde kaydedemiyorum tekrar söylüyorum ben kali nasıl tekrar kurarım biliyorum benim derdim ilerde nasıl kalıyı komple silip yok ederim Windows da gelip kali linux un bulunduğu birimleri diskleri sildiğimde sistemi tekrar başlattığımda hala GUB önyükleyici çıkıyo ve hata veriyo daha önceki silme işleminde böyle oldu ama önemsemedim neden çünkü kaliyi tekrar kuracaktım ama şimdi ise diyorum ki ilerde kaliyi komple sildiğimde hiç bişey kalmasın USB den yapınca beni install etmeye zorluyo

---- Mesajlar birleştirildi ----

lütfen anlayın

---- Mesajlar birleştirildi ----

yada benim anlamadığım yer neresi

---- Mesajlar birleştirildi ----

devam da ediyim burada uğraşırken dedim ki kaliyi komple sileceğim sonra şunları yaptım gittim disk yöneticisinden kali linux un olduğu 2 bölümü sildim tamam mı tamam sonra izlediğim bir video da AOMEI Partition Assistant Unlimited Edition 6.6 ile bölümleri yenile ye tıklamamı istedi onu yaptım sonra yeniden başlattığımda GRUB önyükleyici açılıp Grub rscua (yanlış yazdım) gibisinden hata verdi araştırmaya devam ettim ve bu kez windows da cmd ekranından efi ye girip orada bulunan microsoft,kali gibi dosyalar vardı oradaki "kali" dosyasını silince ve sonrasında yeniden başlattığımda grub recuva diye bir şeyy çıkmaadan direk windows açılıyordu
yanlız boot menu de windows boot banangerin altında hala "kali" gözükmeye devam ediyor du haa işte ben bunu önemsemedim neden çünkü benim dert ettiğim mevzu GRUB da windows gözükmemesi olduğu için önemsemeden tekrardan kaliyi kurdum tabi sonrasında gine GRub da windows gözüükmedi her neyse işte uğraşa uğraaş şimdi burdayız haa şimdi benim sizden istediğimi tekrardan açıklıyorum yukarıda saydığım işlemerde gördüğünüz gibi tam silinmemiş kali ki boot menu de gözüküyor ilerde kaliyi komple silmek istediğimde bu şekilde yarım kalmasını istemiyorum hiç bir yerde kali ile ilgili dosya olmasın işte ilerde bunu yapmak istediğimde nasıl yapacağım :) A dan Z ye anlattım mevzuyu


---- Mesajlar birleştirildi ----

*devam da ediyim burada uğraşırken dedim ki

buraya bir cümle daha ekliyim baya uğraştıktan sonra kaliyi silmeye çalıştım :)

---- Mesajlar birleştirildi ----

forumda baya uğraştıktan sonra burada yani :)
 
Son düzenleme:
Üst